summaryrefslogtreecommitdiff
path: root/user/kleopatra
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-12 03:41:46 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-12 03:41:46 -0500
commit9ec00eeb43258c9b825367261dff6dae6ea9be78 (patch)
tree22b20424788e017fc6b295aa92027a76476cd88f /user/kleopatra
parent8e083ea3bd1a918b47fe73a6764ec483e4dd6bc2 (diff)
downloadpackages-9ec00eeb43258c9b825367261dff6dae6ea9be78.tar.gz
packages-9ec00eeb43258c9b825367261dff6dae6ea9be78.tar.bz2
packages-9ec00eeb43258c9b825367261dff6dae6ea9be78.tar.xz
packages-9ec00eeb43258c9b825367261dff6dae6ea9be78.zip
user/kleopatra: new package
Diffstat (limited to 'user/kleopatra')
-rw-r--r--user/kleopatra/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/user/kleopatra/APKBUILD b/user/kleopatra/APKBUILD
new file mode 100644
index 000000000..8da0ff57d
--- /dev/null
+++ b/user/kleopatra/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=kleopatra
+pkgver=17.08.1
+pkgrel=0
+pkgdesc="Certificate manager and cryptography GUI"
+url="https://www.kde.org/applications/utilities/kleopatra/"
+arch="all"
+license="GPL-2.0"
+options="!check" # Test requires D-Bus session bus.
+depends=""
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev kcmutils-dev
+ kitemmodels-dev gpgme-dev libkleo-dev kmime-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://download.kde.org/stable/applications/$pkgver/src/kleopatra-$pkgver.tar.xz"
+builddir="$srcdir/kleopatra-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="2ecfbeb313d760ac21394a32564d019f8032fa8c3e4ef58d9dfa07da875a22e72cb16793b3b6810ded1068cfc6287986ffd0737bdfb85ff3ce1821ff06ff27e2 kleopatra-17.08.1.tar.xz"