summaryrefslogtreecommitdiff
path: root/user/kmousetool/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 19:54:20 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 19:54:20 +0000
commit289b796f4fb220f55d4f9b067c6f40b9f941d201 (patch)
treefb6a76ab2dde92b72f1e74cdd333cabe5695444a /user/kmousetool/APKBUILD
parent2b10e0a3277c5e5d5d345ff323d9bf4cd0c814ef (diff)
downloadpackages-289b796f4fb220f55d4f9b067c6f40b9f941d201.tar.gz
packages-289b796f4fb220f55d4f9b067c6f40b9f941d201.tar.bz2
packages-289b796f4fb220f55d4f9b067c6f40b9f941d201.tar.xz
packages-289b796f4fb220f55d4f9b067c6f40b9f941d201.zip
user/[KDE Utilities]: Bump to 19.12.0
Diffstat (limited to 'user/kmousetool/APKBUILD')
-rw-r--r--user/kmousetool/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/user/kmousetool/APKBUILD b/user/kmousetool/APKBUILD
index 38d9f4cf8..c744666eb 100644
--- a/user/kmousetool/APKBUILD
+++ b/user/kmousetool/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kmousetool
-pkgver=19.08.2
+pkgver=19.12.0
pkgrel=0
pkgdesc="Tool to assist with clicking the mouse button"
url="https://userbase.kde.org/KMouseTool"
@@ -12,10 +12,9 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev kdbusaddons-dev ki18n-dev
kdoctools-dev kiconthemes-dev knotifications-dev kxmlgui-dev phonon-dev
libxtst-dev libxt-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/applications/$pkgver/src/kmousetool-$pkgver.tar.xz"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmousetool-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -26,18 +25,16 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="a77de3d5a5e5601db7a276e4f14d11ac9d4a63a19231606fafcb959db34ce1d8232b3699dba6749fcf6f7f559f008b43e44e1cecf7746a7764695ec1b482f8ad kmousetool-19.08.2.tar.xz"
+sha512sums="40b93453104394764ad6ed86a0db6e3fee627c4d5d398ee34ee79a94b51c576dfa69a46fcdbf572da7715e4f5210c77c63a57491ad5dfd2a7052f8c5fdbe1c7f kmousetool-19.12.0.tar.xz"