summaryrefslogtreecommitdiff
path: root/user/kpimtextedit
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 19:54:20 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 19:54:20 +0000
commit289b796f4fb220f55d4f9b067c6f40b9f941d201 (patch)
treefb6a76ab2dde92b72f1e74cdd333cabe5695444a /user/kpimtextedit
parent2b10e0a3277c5e5d5d345ff323d9bf4cd0c814ef (diff)
downloadpackages-289b796f4fb220f55d4f9b067c6f40b9f941d201.tar.gz
packages-289b796f4fb220f55d4f9b067c6f40b9f941d201.tar.bz2
packages-289b796f4fb220f55d4f9b067c6f40b9f941d201.tar.xz
packages-289b796f4fb220f55d4f9b067c6f40b9f941d201.zip
user/[KDE Utilities]: Bump to 19.12.0
Diffstat (limited to 'user/kpimtextedit')
-rw-r--r--user/kpimtextedit/APKBUILD14
-rw-r--r--user/kpimtextedit/qt5.9.patch70
2 files changed, 4 insertions, 80 deletions
diff --git a/user/kpimtextedit/APKBUILD b/user/kpimtextedit/APKBUILD
index 686b891b4..f96f924cd 100644
--- a/user/kpimtextedit/APKBUILD
+++ b/user/kpimtextedit/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kpimtextedit
-pkgver=19.08.2
+pkgver=19.12.0
pkgrel=0
pkgdesc="Text editor for Personal Information Managers (PIMs)"
url="https://pim.kde.org/"
@@ -16,12 +16,9 @@ makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev ki18n-dev
kdesignerplugin-dev kemoticons-dev kiconthemes-dev kio-dev kxmlgui-dev
qt5-qtspeech-dev"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.kde.org/stable/applications/$pkgver/src/kpimtextedit-$pkgver.tar.xz
- qt5.9.patch
- "
+source="https://download.kde.org/stable/release-service/$pkgver/src/kpimtextedit-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -32,19 +29,16 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="ef28ec4732fa1322143ded1f4efa27f15111cef2d038d38454b9cd22d32219f63398d764cf1a7cbd29635e9885c2d16463a5b345c22be3b2ea2937727fbff061 kpimtextedit-19.08.2.tar.xz
-3cf800dfc537029588a4701faa2dd1fceb9e0b851c7d7675d468414d45dc2c07aadd4eb687a6b8cfeea4068e1e81b2fe2ad3de7c3c183650d43ab13cf20f4645 qt5.9.patch"
+sha512sums="ddb7ef413ddb17b14b4c44f67304689dca9afbf2aa2002e2267930c5fe7d5eab2b0bef99ca2fea26f6d8c638bbae7b21bc7399dace318a1adba202501470cafd kpimtextedit-19.12.0.tar.xz"
diff --git a/user/kpimtextedit/qt5.9.patch b/user/kpimtextedit/qt5.9.patch
deleted file mode 100644
index 6ae06c8a0..000000000
--- a/user/kpimtextedit/qt5.9.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 6961b54d1c814f2e7aafd7db8256f82688f014a3 Mon Sep 17 00:00:00 2001
-Date: Mon, 17 Dec 2018 07:23:52 +0100
-Subject: Revert "Remove QT_CHECK"
-
----
- .../plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp | 4 ----
- 1 file changed, 4 deletions(-)
-
-diff --git a/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp b/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp
-index 8ce0fe9..c07699c 100644
---- a/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp
-+++ b/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp
-@@ -144,9 +144,13 @@ void PlainTextSyntaxSpellCheckingHighlighter::highlightBlock(const QString &text
-
- const auto nextBlock = currentBlock().next();
- if (nextBlock.isValid()) {
-+#if QT_VERSION >= QT_VERSION_CHECK(5, 10, 0)
- QMetaObject::invokeMethod(this, [this, nextBlock] {
- rehighlightBlock(nextBlock);
- }, Qt::QueuedConnection);
-+#else
-+ QMetaObject::invokeMethod(this, "rehighlightBlock", Qt::QueuedConnection, Q_ARG(QTextBlock, nextBlock));
-+#endif
- }
- }
-
---
-cgit v1.1
-
---- kpimtextedit-19.04.0/CMakeLists.txt.old 2019-04-12 00:14:22.000000000 +0000
-+++ kpimtextedit-19.04.0/CMakeLists.txt 2019-04-19 06:21:56.055556133 +0000
-@@ -4,7 +4,7 @@
- project(KPimTextEdit VERSION ${PIM_VERSION})
-
- # ECM setup
--set(KF5_MIN_VERSION "5.60.0")
-+set(KF5_MIN_VERSION "5.54.0")
-
- find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)
- set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
-@@ -36,7 +36,7 @@
- SOVERSION 5
- )
-
--set(QT_REQUIRED_VERSION "5.11.0")
-+set(QT_REQUIRED_VERSION "5.9.0")
- find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED COMPONENTS Widgets)
- find_package(Grantlee5 "5.1" CONFIG REQUIRED)
- set_package_properties(Grantlee5 PROPERTIES
---- kpimtextedit-19.08.0/CMakeLists.txt.old 2019-08-15 14:58:32.623688389 +0000
-+++ kpimtextedit-19.08.0/CMakeLists.txt 2019-08-15 14:59:20.798530990 +0000
-@@ -114,7 +114,7 @@
- COMPONENT Devel
- )
-
--install(FILES kpimtextedit.categories DESTINATION ${KDE_INSTALL_LOGGINGCATEGORIESDIR})
-+#install(FILES kpimtextedit.categories DESTINATION ${KDE_INSTALL_LOGGINGCATEGORIESDIR})
-
-
- feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
---- kpimtextedit-19.08.0/CMakeLists.txt.old 2019-08-15 14:59:35.306977776 +0000
-+++ kpimtextedit-19.08.0/CMakeLists.txt 2019-08-15 15:00:30.421077488 +0000
-@@ -68,7 +68,6 @@
- add_definitions(-DTRANSLATION_DOMAIN=\"libkpimtextedit\")
-
- add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x060000)
--add_definitions(-DQT_NO_FOREACH)
-
- find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED COMPONENTS TextToSpeech)
-