summaryrefslogtreecommitdiff
path: root/user/kpmcore/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 18:08:58 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 18:08:58 +0000
commit4aa7cd02d3a11034316d4a878a493e2507d26797 (patch)
tree14c250adf4d8ee51b1e4418e6cfdec11d01e3643 /user/kpmcore/APKBUILD
parent98c3f05e07b419212d0f6ba49da7ff81fd62aa58 (diff)
downloadpackages-4aa7cd02d3a11034316d4a878a493e2507d26797.tar.gz
packages-4aa7cd02d3a11034316d4a878a493e2507d26797.tar.bz2
packages-4aa7cd02d3a11034316d4a878a493e2507d26797.tar.xz
packages-4aa7cd02d3a11034316d4a878a493e2507d26797.zip
user/kpmcore: Bump to 4.0.1, fix issues
* FAT32 partitions were using the exFAT MBR code. * Use-before-init when closing partitionmanager sometimes. * Remove broken test.
Diffstat (limited to 'user/kpmcore/APKBUILD')
-rw-r--r--user/kpmcore/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/user/kpmcore/APKBUILD b/user/kpmcore/APKBUILD
index a6fef6476..654bf76a1 100644
--- a/user/kpmcore/APKBUILD
+++ b/user/kpmcore/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kpmcore
-pkgver=3.3.0
+pkgver=4.0.1
pkgrel=0
pkgdesc="Core routines for KDE Partition Manager"
url="https://www.kde.org/applications/system/partitionmanager"
@@ -10,12 +10,15 @@ license="LGPL-2.1+"
depends=""
depends_dev="libatasmart-dev parted-dev qt5-qtbase-dev"
makedepends="$depends_dev cmake extra-cmake-modules kcoreaddons-dev ki18n-dev
- kwidgetsaddons-dev util-linux-dev"
+ kwidgetsaddons-dev util-linux-dev kauth-dev qca-dev"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.kde.org/stable/kpmcore/$pkgver/src/kpmcore-$pkgver.tar.xz"
+source="https://download.kde.org/stable/kpmcore/$pkgver/src/kpmcore-$pkgver.tar.xz
+ fat32.patch
+ nullptr-segfault.patch
+ test.patch
+ "
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -26,18 +29,19 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="62a0a341fbbec426291e2c9dd183a20466fce48ffaa360dd816c58402ee03c1f61c4ef7887d0a66c4693d77c2183a5da3477b828ba4ac2ed405f684ffb27125e kpmcore-3.3.0.tar.xz"
+sha512sums="982ad77246f59ade74edba15effca6490ac9ac7bb6db7f6194bcdbfddfa735c9bc1b58020affccd945fcdfc96fce3488167f492d6a13dcd6d19c5692505303ac kpmcore-4.0.1.tar.xz
+904897b7e9292a33c131af9c65d3aa4eaca8cb84a437b83ac76bd8ee7347b49c7c098254ca03f72ab17a8c4f224b31e950978f3bc2c76953d60e38835faab9d7 fat32.patch
+cfcce896034c636bdea7ef36548e8116cfd7c0d92e76c4034f6b87b93efc943bb7a475325b2ac178dfb753178cff615603b2aca42a245a3bfda80ffa9c444ea4 nullptr-segfault.patch
+2b51fc26188f88fe5d6942ece062d19810ba35471f47005838fa812e8ecc78d25240a08e9e5d824f37da1284dd991323542d295519a6bdc89138c48d256e331b test.patch"