summaryrefslogtreecommitdiff
path: root/user/kpmcore/test.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-06-12 17:14:16 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:34:01 -0500
commit6bf730941205e61bf6d7ff9d4fe4bc5594e67a11 (patch)
tree7bac7b306eac1ec027bf6cb72785dc2985dc7fb0 /user/kpmcore/test.patch
parent73f8ae93e7e9df25876d730914e080a727c62476 (diff)
downloadpackages-6bf730941205e61bf6d7ff9d4fe4bc5594e67a11.tar.gz
packages-6bf730941205e61bf6d7ff9d4fe4bc5594e67a11.tar.bz2
packages-6bf730941205e61bf6d7ff9d4fe4bc5594e67a11.tar.xz
packages-6bf730941205e61bf6d7ff9d4fe4bc5594e67a11.zip
user/[KDE Partition Manager]: Update to 22.04.2
Diffstat (limited to 'user/kpmcore/test.patch')
-rw-r--r--user/kpmcore/test.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/user/kpmcore/test.patch b/user/kpmcore/test.patch
new file mode 100644
index 000000000..e969cb91d
--- /dev/null
+++ b/user/kpmcore/test.patch
@@ -0,0 +1,42 @@
+From 26e069d6cdd2d28b04f0beb9cfb35115ac8f29d5 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Sun, 12 Jun 2022 16:14:51 -0500
+Subject: [PATCH] Tests: Fix backend loading for tests
+
+Using $<TARGET_FILE> we receive the entire plugin file path, leading to
+errors such as:
+
+kf.coreaddons: no metadata found in "kpmcore//home/awilcox/Code/KDE/kpmcore/bin/kpmcore/pmdummybackendplugin.so" "The shared library was not found."
+
+Using $<TARGET_FILE_NAME> instead we are able to have just the plugin
+name, which does load properly. The tests now pass.
+---
+ test/CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index 262c38f..53cb133 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -34,15 +34,15 @@ endmacro()
+ # Tests of initialization: try explicitly loading some backends
+ kpm_test(testinit testinit.cpp) # Default backend
+ if(TARGET pmdummybackendplugin)
+- add_test(NAME testinit-dummy COMMAND testinit $<TARGET_FILE:pmdummybackendplugin>)
++ add_test(NAME testinit-dummy COMMAND testinit $<TARGET_FILE_NAME:pmdummybackendplugin>)
+ endif()
+ if(TARGET pmsfdiskbackendplugin)
+- add_test(NAME testinit-sfdisk COMMAND testinit $<TARGET_FILE:pmsfdiskbackendplugin>)
++ add_test(NAME testinit-sfdisk COMMAND testinit $<TARGET_FILE_NAME:pmsfdiskbackendplugin>)
+ else()
+ return() # All the rest really needs a working backend
+ endif()
+
+-set(BACKEND $<TARGET_FILE:pmsfdiskbackendplugin>)
++set(BACKEND $<TARGET_FILE_NAME:pmsfdiskbackendplugin>)
+
+ ###
+ #
+--
+GitLab
+