summaryrefslogtreecommitdiff
path: root/user/ksquares
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-14 01:56:10 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-14 01:56:10 -0500
commita45801bbe7260de542f82d29a9e2afdeb11371fc (patch)
tree0f02b7b2b25a1ef6153db77d2975e5369501417e /user/ksquares
parentcb0652432815c7ed35139da14f8d229661951160 (diff)
downloadpackages-a45801bbe7260de542f82d29a9e2afdeb11371fc.tar.gz
packages-a45801bbe7260de542f82d29a9e2afdeb11371fc.tar.bz2
packages-a45801bbe7260de542f82d29a9e2afdeb11371fc.tar.xz
packages-a45801bbe7260de542f82d29a9e2afdeb11371fc.zip
user/ksquares: new package
Diffstat (limited to 'user/ksquares')
-rw-r--r--user/ksquares/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/user/ksquares/APKBUILD b/user/ksquares/APKBUILD
new file mode 100644
index 000000000..ca46bf91f
--- /dev/null
+++ b/user/ksquares/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=ksquares
+pkgver=17.08.1
+pkgrel=0
+pkgdesc="Fun and exciting game of Dots and Boxes"
+url="https://games.kde.org/game.php?game=ksquares"
+arch="all"
+license="GPL-2.0"
+depends=""
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev kconfigwidgets-dev
+ kconfig-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev kdoctools-dev
+ ki18n-dev kwidgetsaddons-dev kxmlgui-dev libkdegames-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://download.kde.org/stable/applications/$pkgver/src/ksquares-$pkgver.tar.xz"
+builddir="$srcdir/ksquares-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="86d61c0d674a387ca8ae7d19208540d2f12afc4c79e1c0859e2065ad6f9cfccda17f470fd5ee049c4ef7bf7faba78b33f1cbbc1407d4d1de0e8f71d8160f440b ksquares-17.08.1.tar.xz"