summaryrefslogtreecommitdiff
path: root/user/kst
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 01:57:58 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 01:57:58 +0000
commit1b5ac6b603626d26dbb3484ae4cb7624cb18a620 (patch)
tree9041a4b00af7a77dac1b32806fb24d03fbe30134 /user/kst
parenteb2ee1e3dc396b3dcf52e391c7227faaeb858d20 (diff)
downloadpackages-1b5ac6b603626d26dbb3484ae4cb7624cb18a620.tar.gz
packages-1b5ac6b603626d26dbb3484ae4cb7624cb18a620.tar.bz2
packages-1b5ac6b603626d26dbb3484ae4cb7624cb18a620.tar.xz
packages-1b5ac6b603626d26dbb3484ae4cb7624cb18a620.zip
user/*: Modernise / fix syntax / deps / code
Diffstat (limited to 'user/kst')
-rw-r--r--user/kst/APKBUILD12
-rw-r--r--user/kst/qt5.patch47
2 files changed, 53 insertions, 6 deletions
diff --git a/user/kst/APKBUILD b/user/kst/APKBUILD
index d87b6e693..c47aa32e3 100644
--- a/user/kst/APKBUILD
+++ b/user/kst/APKBUILD
@@ -12,11 +12,12 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qttools-dev gsl-dev"
subpackages="$pkgname-doc $pkgname-lang"
langdir="/usr/share/kst/locale"
source="https://downloads.sourceforge.net/project/kst/Kst%20$pkgver/Kst-$pkgver.tar.gz
- kst-gsl2.patch"
+ kst-gsl2.patch
+ qt5.patch
+ "
builddir="$srcdir/Kst-$pkgver"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -29,19 +30,18 @@ build() {
-DCMAKE_C_FLAGS="$CFLAGS" \
-Dkst_qt5="YesPlease" \
-Dkst_install_prefix="/usr" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="81be1e9ef189dbf087c5626b984297d4c8f84f22fce50c4933ea467a65f8595c0254af78d55f2b2e324934346f0758b7a0cf48d06d1108026b60b7ffba1221fb Kst-2.0.8.tar.gz
-1dbd94d7e4298d768ab1e9e020dd207b848e72b30db6b1f2ef2f3eb0d528ec5c0a120593e7e7c06f4cb1e59e950a965e217c30564a26510a180d82418628d4e5 kst-gsl2.patch"
+1dbd94d7e4298d768ab1e9e020dd207b848e72b30db6b1f2ef2f3eb0d528ec5c0a120593e7e7c06f4cb1e59e950a965e217c30564a26510a180d82418628d4e5 kst-gsl2.patch
+63705a561890792a1d3cced65075a46d0f507f5abf2599de6475491d7484bba3102152c8fe13a6d3c424e409e6b6070299208d09f74282137b6e95acc95df879 qt5.patch"
diff --git a/user/kst/qt5.patch b/user/kst/qt5.patch
new file mode 100644
index 000000000..64c5d3c40
--- /dev/null
+++ b/user/kst/qt5.patch
@@ -0,0 +1,47 @@
+From 9fc5140791ec00d6df2d65973f3ca61df17b1d47 Mon Sep 17 00:00:00 2001
+From: Christophe Giboudeaux <christophe@krop.fr>
+Date: Sun, 3 Jun 2018 19:43:34 +0200
+Subject: Fix build with Qt 5.11
+
+Summary:
+- qt5_use_modules was removed in Qt 5.11. use target_link_libraries instead.
+- Add a missing #include
+
+Subscribers: kde-edu
+
+Tags: #kde_edu
+
+Differential Revision: https://phabricator.kde.org/D13339
+---
+ cmake/modules/KstMacros.cmake | 2 +-
+ src/libkstapp/view.h | 1 +
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/cmake/modules/KstMacros.cmake b/cmake/modules/KstMacros.cmake
+index 4ff9c15..bc3d8a6 100644
+--- a/cmake/modules/KstMacros.cmake
++++ b/cmake/modules/KstMacros.cmake
+@@ -240,7 +240,7 @@ endmacro()
+ macro(kst_link)
+ target_link_libraries(${kst_name} ${ARGV})
+ if(kst_qt5)
+- qt5_use_modules(${kst_name} Widgets Xml Network PrintSupport)
++ target_link_libraries(${kst_name} Qt5::Widgets Qt5::Xml Qt5::Network Qt5::PrintSupport)
+ else()
+ target_link_libraries(${kst_name}
+ ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTSVG_LIBRARY} ${QT_QTNETWORK_LIBRARY})
+diff --git a/src/libkstapp/view.h b/src/libkstapp/view.h
+index 95c8c6a..2af5393 100644
+--- a/src/libkstapp/view.h
++++ b/src/libkstapp/view.h
+@@ -14,6 +14,7 @@
+ #define VIEW_H
+
+ #include <QGraphicsView>
++#include <QMenu>
+
+ #include "kst_export.h"
+
+--
+cgit v1.1
+