summaryrefslogtreecommitdiff
path: root/user/ktexteditor
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-12-10 18:57:19 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-12-10 18:57:53 -0600
commit286c02f41ebcbdef36acc5524fdc646a74b64630 (patch)
treebb7c8444dbdd2c16567354cb3f0ada0e74e967e9 /user/ktexteditor
parent9d757918eaa2a75d6d913b9d5de699940dc4b1d3 (diff)
downloadpackages-286c02f41ebcbdef36acc5524fdc646a74b64630.tar.gz
packages-286c02f41ebcbdef36acc5524fdc646a74b64630.tar.bz2
packages-286c02f41ebcbdef36acc5524fdc646a74b64630.tar.xz
packages-286c02f41ebcbdef36acc5524fdc646a74b64630.zip
KDE Frameworks 5.41 bump
Diffstat (limited to 'user/ktexteditor')
-rw-r--r--user/ktexteditor/APKBUILD8
-rw-r--r--user/ktexteditor/improper-indentation-fix.patch32
2 files changed, 3 insertions, 37 deletions
diff --git a/user/ktexteditor/APKBUILD b/user/ktexteditor/APKBUILD
index d1a0de853..837d2795d 100644
--- a/user/ktexteditor/APKBUILD
+++ b/user/ktexteditor/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=ktexteditor
-pkgver=5.39.0
+pkgver=5.41.0
pkgrel=1
pkgdesc="Reusable, programmable text editor widget"
url="https://www.kde.org/"
@@ -16,8 +16,7 @@ makedepends="$depends_dev cmake extra-cmake-modules python3 gettext-dev doxygen
graphviz qt5-qttools-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://download.kde.org/stable/frameworks/${pkgver%.*}/ktexteditor-$pkgver.tar.xz
- improper-indentation-fix.patch"
+source="http://download.kde.org/stable/frameworks/${pkgver%.*}/ktexteditor-$pkgver.tar.xz"
builddir="$srcdir/ktexteditor-$pkgver"
build() {
@@ -47,5 +46,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="a76828be990bd32275f7de2448e337750aa1766eed669aa7a8c199d3d7db002c9d2193d09cac789c73d7cee783b9b85a21f50563e5beff30fac484f414145f6f ktexteditor-5.39.0.tar.xz
-0ffae497093583e1cae3a0d65750fc9d687b799d40fe0dd1f27a464ab1b4862fd265cb7ba0d9367e9dcd5d80c324f8453cf928ace619d1e68b3a43f9f3e7d01b improper-indentation-fix.patch"
+sha512sums="a8cc6ce4a85669d9fe1062e85a1d170498db6de0cd7256143caf60cb454c31dac7920cea6d12ff6dfb109c579a86c3fb4d33add1b104724cba00a4bc00a1fa7b ktexteditor-5.41.0.tar.xz"
diff --git a/user/ktexteditor/improper-indentation-fix.patch b/user/ktexteditor/improper-indentation-fix.patch
deleted file mode 100644
index fc5d9d9d3..000000000
--- a/user/ktexteditor/improper-indentation-fix.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From aeebeadb5f5955995c17de56cf83ba7166a132dd Mon Sep 17 00:00:00 2001
-From: Sven Brauch <mail@svenbrauch.de>
-Date: Mon, 16 Oct 2017 18:35:50 +0200
-Subject: fix some indenters from indenting on random characters
-
-If triggerCharacters was not set, toString() would return "undefined",
-making indenters trigger on u, n, d, e, f, i and n.
-
-Differential Revision: https://phabricator.kde.org/D8333
----
- src/script/kateindentscript.cpp | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/src/script/kateindentscript.cpp b/src/script/kateindentscript.cpp
-index 15ce387..380bd45 100644
---- a/src/script/kateindentscript.cpp
-+++ b/src/script/kateindentscript.cpp
-@@ -46,7 +46,10 @@ const QString &KateIndentScript::triggerCharacters()
-
- m_triggerCharactersSet = true;
-
-- m_triggerCharacters = global(QStringLiteral("triggerCharacters")).toString();
-+ auto triggerCharacters = global(QStringLiteral("triggerCharacters"));
-+ if ( !triggerCharacters.isUndefined() ) {
-+ m_triggerCharacters = triggerCharacters.toString();
-+ }
-
- //qCDebug(LOG_KTE) << "trigger chars: '" << m_triggerCharacters << "'";
-
---
-cgit v0.11.2
-