summaryrefslogtreecommitdiff
path: root/user/ktorrent
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-17 18:41:29 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-17 18:41:29 -0500
commit76eb3d6b457e6b9c431eba9a25d7656f71454e6e (patch)
tree031c7592ec690e83664d11ddaa2fdc5ed0244a91 /user/ktorrent
parent9b2e7237a2d377725d3f63c631655e5de95762f2 (diff)
downloadpackages-76eb3d6b457e6b9c431eba9a25d7656f71454e6e.tar.gz
packages-76eb3d6b457e6b9c431eba9a25d7656f71454e6e.tar.bz2
packages-76eb3d6b457e6b9c431eba9a25d7656f71454e6e.tar.xz
packages-76eb3d6b457e6b9c431eba9a25d7656f71454e6e.zip
user/ktorrent: new package
Diffstat (limited to 'user/ktorrent')
-rw-r--r--user/ktorrent/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/user/ktorrent/APKBUILD b/user/ktorrent/APKBUILD
new file mode 100644
index 000000000..7a401cac9
--- /dev/null
+++ b/user/ktorrent/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=ktorrent
+pkgver=5.1.0
+pkgrel=0
+pkgdesc="BitTorrent client by KDE"
+url="https://www.kde.org/applications/internet/ktorrent/"
+arch="all"
+license="GPL-2.0-only"
+depends=""
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtscript-dev kio-dev
+ kconfig-dev kconfigwidgets-dev kcoreaddons-dev kcrash-dev ki18n-dev
+ kdbusaddons-dev kiconthemes-dev knotifications-dev knotifyconfig-dev
+ kcmutils-dev kparts-dev kservice-dev solid-dev kwidgetsaddons-dev
+ kwindowsystem-dev kxmlgui-dev libktorrent-dev taglib-dev kplotting-dev
+ kdnssd-dev plasma-workspace-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.kde.org/stable/ktorrent/5.1/ktorrent-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="7bfe3a04a2b0f62d68b41c946af34e9f6ead6aa4ff7818a9c0ce2e83629d311e9e9be5fb1689065ce2601c43bd576b27d8c6946b845d4cdf5fa6362d53e8dd25 ktorrent-5.1.0.tar.xz"