summaryrefslogtreecommitdiff
path: root/user/libavc1394
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-21 02:41:43 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-21 02:41:43 -0500
commit6e7a0124602fdd8475eb132b0de8ad9e68595939 (patch)
treefd9bd8c07ee504a2d89b7cf606b2ef0c713850f8 /user/libavc1394
parent96236b7403b76c2e202b9390adf272f05eee2b27 (diff)
downloadpackages-6e7a0124602fdd8475eb132b0de8ad9e68595939.tar.gz
packages-6e7a0124602fdd8475eb132b0de8ad9e68595939.tar.bz2
packages-6e7a0124602fdd8475eb132b0de8ad9e68595939.tar.xz
packages-6e7a0124602fdd8475eb132b0de8ad9e68595939.zip
user/libavc1394: pull in, fix up, modernise, fix license
Diffstat (limited to 'user/libavc1394')
-rw-r--r--user/libavc1394/APKBUILD50
-rw-r--r--user/libavc1394/argp.patch11
-rw-r--r--user/libavc1394/automake.patch10
3 files changed, 71 insertions, 0 deletions
diff --git a/user/libavc1394/APKBUILD b/user/libavc1394/APKBUILD
new file mode 100644
index 000000000..5fd7c7ef6
--- /dev/null
+++ b/user/libavc1394/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=libavc1394
+pkgver=0.5.4
+pkgrel=3
+pkgdesc="Audio/Video control library for FireWire devices"
+url="https://sourceforge.net/projects/libavc1394/"
+arch="all"
+license="LGPL-2.1+"
+depends=""
+makedepends="libraw1394-dev libtool automake autoconf"
+[ "$CLIBC" != "eglibc" ] && makedepends="$makedepends argp-standalone"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/libavc1394/libavc1394-$pkgver.tar.gz
+ automake.patch
+ argp.patch"
+
+prepare() {
+ cd "$builddir"
+ update_config_sub
+ default_prepare
+ libtoolize && aclocal && autoconf && automake --add-missing
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ef07631cd2de9b79dec9d81247d705be318101e8f8a1fe007b946ffab3dfe7b97f392144614d867ef6b2315b6c0e82d53e915f07855d4e21401645293e18842a libavc1394-0.5.4.tar.gz
+8854bed6b9efa4b2bb56762614bcbceadb5cb1cdd393fd676476d40672cc3965962da764543f8628f51567a32ecf5035edb35b883b8963f94bce034ff4793c11 automake.patch
+77bf60530b6b81f6bd3c69a11de7ac015f1182fcd8c2586d0fd9605818c3ccde310c386f30c00166853a405f60c13bf6b2d304327ec181de28609c58b215ab31 argp.patch"
diff --git a/user/libavc1394/argp.patch b/user/libavc1394/argp.patch
new file mode 100644
index 000000000..9c86a625e
--- /dev/null
+++ b/user/libavc1394/argp.patch
@@ -0,0 +1,11 @@
+--- ./configure.in.orig
++++ ./configure.in
+@@ -11,6 +11,8 @@
+
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(sys/time.h sys/types.h unistd.h string.h netinet/in.h stdio.h)
++AC_SEARCH_LIBS([argp_usage], [argp], [],
++ [AC_MSG_ERROR([argp not found. Consider installing argp-standalone])])
+ PKG_CHECK_MODULES(LIBRAW1394, libraw1394 >= 1.0.0)
+
+ #set the libtool shared library version numbers
diff --git a/user/libavc1394/automake.patch b/user/libavc1394/automake.patch
new file mode 100644
index 000000000..9bb6280ae
--- /dev/null
+++ b/user/libavc1394/automake.patch
@@ -0,0 +1,10 @@
+--- ./configure.in.orig 2012-12-31 19:52:37.126761564 +0000
++++ ./configure.in 2012-12-31 19:52:55.096923632 +0000
+@@ -1,6 +1,6 @@
+ AC_INIT(Makefile.am)
+ AM_INIT_AUTOMAKE(libavc1394, 0.5.4)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADER(config.h)
+ AM_MAINTAINER_MODE
+
+ AC_PROG_CC