summaryrefslogtreecommitdiff
path: root/user/libktorrent
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-15 19:30:58 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-15 19:30:58 -0500
commit081961a1f9a8075a6ca87ef7822594cd44c2fb6b (patch)
tree53795e01106d841995c69f7652cd0a1b7e14d3af /user/libktorrent
parent67279ceceea86972ce21921c838d4a7f7ba942dd (diff)
downloadpackages-081961a1f9a8075a6ca87ef7822594cd44c2fb6b.tar.gz
packages-081961a1f9a8075a6ca87ef7822594cd44c2fb6b.tar.bz2
packages-081961a1f9a8075a6ca87ef7822594cd44c2fb6b.tar.xz
packages-081961a1f9a8075a6ca87ef7822594cd44c2fb6b.zip
user/libktorrent: new package
Diffstat (limited to 'user/libktorrent')
-rw-r--r--user/libktorrent/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/user/libktorrent/APKBUILD b/user/libktorrent/APKBUILD
new file mode 100644
index 000000000..39d2b0cb7
--- /dev/null
+++ b/user/libktorrent/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libktorrent
+pkgver=2.1
+pkgrel=0
+pkgdesc="Torrent handling library for KDE"
+url="https://www.kde.org/"
+arch="all"
+license="LGPL-2.1+"
+depends=""
+depends_dev="qt5-qtbase-dev karchive-dev kcrash-dev kio-dev solid-dev gmp-dev
+ boost-dev qca-dev"
+makedepends="cmake extra-cmake-modules $depends_dev ki18n-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://download.kde.org/stable/ktorrent/5.1/libktorrent-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="28d7a4b8ee45ddcbadb3ca9d6e568120803081b0ecd3e9436ed721860717b98538c522653ea47975123f0819548d0cabe1973baffed887fcbbca11d84ea5ebe4 libktorrent-2.1.tar.xz"