summaryrefslogtreecommitdiff
path: root/user/libmatroska
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 23:23:18 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 23:23:18 +0000
commitc33214f0f31529c15696bee344e08abb1446e996 (patch)
tree5f093429d177905cbdaaec66aeaa535a4e8e304f /user/libmatroska
parent33b95bdbff212f69a303f61b9235839c127cc17d (diff)
downloadpackages-c33214f0f31529c15696bee344e08abb1446e996.tar.gz
packages-c33214f0f31529c15696bee344e08abb1446e996.tar.bz2
packages-c33214f0f31529c15696bee344e08abb1446e996.tar.xz
packages-c33214f0f31529c15696bee344e08abb1446e996.zip
user/*: Modernise / fix syntax / deps
Diffstat (limited to 'user/libmatroska')
-rw-r--r--user/libmatroska/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/user/libmatroska/APKBUILD b/user/libmatroska/APKBUILD
index 6a8ea1f9d..076e9a9e2 100644
--- a/user/libmatroska/APKBUILD
+++ b/user/libmatroska/APKBUILD
@@ -8,24 +8,23 @@ url="https://www.matroska.org/"
arch="all"
options="!check" # No test suite.
license="LGPL-2.1+"
-makedepends="libebml-dev>=1.3.3"
+depends=""
+makedepends="cmake libebml-dev>=1.3.3"
subpackages="$pkgname-dev"
source="https://dl.matroska.org/downloads/$pkgname/$pkgname-$pkgver.tar.xz"
build() {
- cd "$builddir"
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS"
+ -DCMAKE_C_FLAGS="$CFLAGS" .
make
}
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir"
}