summaryrefslogtreecommitdiff
path: root/user/libnftnl/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-01-13 19:44:23 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-01-13 19:44:23 +0000
commitdadc93d1b35aa2336bbd46cc590dabd5d844bb0e (patch)
tree907612528285f1df404f5de34942c21f247fd568 /user/libnftnl/APKBUILD
parentb818b871b17b09a6adc0b43f8e65977bab5104a6 (diff)
parenta21b49c9ed1b34c463560d31c0cbeead46810038 (diff)
downloadpackages-dadc93d1b35aa2336bbd46cc590dabd5d844bb0e.tar.gz
packages-dadc93d1b35aa2336bbd46cc590dabd5d844bb0e.tar.bz2
packages-dadc93d1b35aa2336bbd46cc590dabd5d844bb0e.tar.xz
packages-dadc93d1b35aa2336bbd46cc590dabd5d844bb0e.zip
Merge branch 'nftables' into 'master'
nftables + dependencies: new packages This MR contains APKBUILDs for nftables and its libnftnl dependency. APKBUILDs have been adapted and trimmed from Alpine; the OpenRC scripts come indirectly from Gentoo via Alpine. Tested on x86_64 by NAT'ing a couple of VM's to the outside world. See merge request !145
Diffstat (limited to 'user/libnftnl/APKBUILD')
-rw-r--r--user/libnftnl/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/libnftnl/APKBUILD b/user/libnftnl/APKBUILD
new file mode 100644
index 000000000..432f60b07
--- /dev/null
+++ b/user/libnftnl/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=libnftnl
+pkgver=1.1.2
+pkgrel=0
+pkgdesc="Netfilter library providing interface to the nf_tables subsystem"
+url="https://netfilter.org/projects/libnftnl"
+arch="all"
+license="GPL-2.0+"
+makedepends="libmnl-dev"
+subpackages="$pkgname-dev"
+source="https://netfilter.org/projects/libnftnl/files/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"/tests
+ make check # builds test binaries
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="808e0efd2ff32a65cca1e6113cc29aece1335364b94ad87438d19b0887d0bd34de11942fa411e4105ef153f2cce862ded17ebc441c413b839ac506471e530569 libnftnl-1.1.2.tar.bz2"