summaryrefslogtreecommitdiff
path: root/user/libnftnl
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 11:42:56 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 11:42:56 +0000
commitcf1fe262fdd1fa284ac17eba53bdc957a510b1e2 (patch)
treebf3d5bc8d49b04baeed607edd61fe2d9e0b95eb5 /user/libnftnl
parentfd785aca5b4fbf8d3b1823db182c0cc83b208e00 (diff)
downloadpackages-cf1fe262fdd1fa284ac17eba53bdc957a510b1e2.tar.gz
packages-cf1fe262fdd1fa284ac17eba53bdc957a510b1e2.tar.bz2
packages-cf1fe262fdd1fa284ac17eba53bdc957a510b1e2.tar.xz
packages-cf1fe262fdd1fa284ac17eba53bdc957a510b1e2.zip
user/libnftnl: Bump to 1.1.5
Diffstat (limited to 'user/libnftnl')
-rw-r--r--user/libnftnl/APKBUILD9
-rw-r--r--user/libnftnl/nft-flowtable-test.patch37
2 files changed, 43 insertions, 3 deletions
diff --git a/user/libnftnl/APKBUILD b/user/libnftnl/APKBUILD
index 3b08ef8cc..b634ff0c2 100644
--- a/user/libnftnl/APKBUILD
+++ b/user/libnftnl/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Luis Ressel <aranea@aixah.de>
# Maintainer:
pkgname=libnftnl
-pkgver=1.1.4
+pkgver=1.1.5
pkgrel=0
pkgdesc="Netfilter library providing interface to the nf_tables subsystem"
url="https://netfilter.org/projects/libnftnl"
@@ -11,7 +11,9 @@ license="GPL-2.0+"
depends=""
makedepends="libmnl-dev"
subpackages="$pkgname-dev"
-source="https://netfilter.org/projects/libnftnl/files/$pkgname-$pkgver.tar.bz2"
+source="https://netfilter.org/projects/libnftnl/files/$pkgname-$pkgver.tar.bz2
+ nft-flowtable-test.patch
+ "
build() {
./configure \
@@ -32,4 +34,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="6fe248b1340decc1ec8ae40dd0ed60b8d4b819c2f36f2399d39e13e92fc5e6f6ec693b736d6c188bff954afb2bf2dbce67d54a9e664b45f43288b2c5c6cc08f6 libnftnl-1.1.4.tar.bz2"
+sha512sums="a0495e1a99ea9efcf3994db48e50943023ff3d8101055887574ff4eb6b0df8600cf7db68a9c91ca02bbbcc1f01099b008649f88321bb956897bcc90eb4167ee7 libnftnl-1.1.5.tar.bz2
+0978037a5dec71a96f5713dbc5a4dc8dc30b7b37d79ec7dd6ec8b201740303785c3625c21a2388f8fd5d9d446f8706ac14d0bf5909a48ed3ef3e7417173dd2c8 nft-flowtable-test.patch"
diff --git a/user/libnftnl/nft-flowtable-test.patch b/user/libnftnl/nft-flowtable-test.patch
new file mode 100644
index 000000000..719c1f2cf
--- /dev/null
+++ b/user/libnftnl/nft-flowtable-test.patch
@@ -0,0 +1,37 @@
+From b2388765e0c4405442faa13845419f6a35d0134c Mon Sep 17 00:00:00 2001
+From: Phil Sutter <phil@nwl.cc>
+Date: Mon, 2 Dec 2019 18:29:56 +0100
+Subject: tests: flowtable: Don't check NFTNL_FLOWTABLE_SIZE
+
+Marshalling code around that attribute has been dropped by commit
+d1c4b98c733a5 ("flowtable: remove NFTA_FLOWTABLE_SIZE") so it's value is
+lost during the test.
+
+Assuming that NFTNL_FLOWTABLE_SIZE will receive kernel support at a
+later point, leave the test code in place but just comment it out.
+
+Fixes: d1c4b98c733a5 ("flowtable: remove NFTA_FLOWTABLE_SIZE")
+Signed-off-by: Phil Sutter <phil@nwl.cc>
+Acked-by: Pablo Neira Ayuso <pablo@netfilter.org>
+---
+ tests/nft-flowtable-test.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tests/nft-flowtable-test.c b/tests/nft-flowtable-test.c
+index 3edb00d..8ab8d4c 100644
+--- a/tests/nft-flowtable-test.c
++++ b/tests/nft-flowtable-test.c
+@@ -33,9 +33,11 @@ static void cmp_nftnl_flowtable(struct nftnl_flowtable *a, struct nftnl_flowtabl
+ if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_USE) !=
+ nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_USE))
+ print_err("Flowtable use mismatches");
++#if 0
+ if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_SIZE) !=
+ nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_SIZE))
+ print_err("Flowtable size mismatches");
++#endif
+ if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_FLAGS) !=
+ nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_FLAGS))
+ print_err("Flowtable flags mismatches");
+--
+2.24.1