summaryrefslogtreecommitdiff
path: root/user/libnih/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 07:29:00 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 07:29:00 -0600
commitd00b149bc5c53bc3215e94c57a6ea5257ec37647 (patch)
tree98e3a8c25f26cb27ff4394e6f8598324af615f59 /user/libnih/APKBUILD
parent52bf3b0d577c4c42fa1d3839ed1b3a9ac95145ca (diff)
downloadpackages-d00b149bc5c53bc3215e94c57a6ea5257ec37647.tar.gz
packages-d00b149bc5c53bc3215e94c57a6ea5257ec37647.tar.bz2
packages-d00b149bc5c53bc3215e94c57a6ea5257ec37647.tar.xz
packages-d00b149bc5c53bc3215e94c57a6ea5257ec37647.zip
user/[libraries]: modernise and fix syntax
Diffstat (limited to 'user/libnih/APKBUILD')
-rw-r--r--user/libnih/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/user/libnih/APKBUILD b/user/libnih/APKBUILD
index 9636f2a1a..3808dc3a7 100644
--- a/user/libnih/APKBUILD
+++ b/user/libnih/APKBUILD
@@ -10,8 +10,8 @@ options="!checkroot"
license="GPL-2.0-only"
depends=""
depends_dev="dbus-dev expat-dev"
-makedepends="$depends_dev"
checkdepends="dbus linux-headers"
+makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://launchpad.net/libnih/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz
musl-fix-signals.patch
@@ -21,13 +21,11 @@ source="https://launchpad.net/libnih/${pkgver%.*}/${pkgver}/+download/${pkgname}
"
prepare() {
- cd "$builddir"
- update_config_sub
default_prepare
+ update_config_sub
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,12 +37,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}