summaryrefslogtreecommitdiff
path: root/user/libnl3
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-07-21 19:44:28 -0400
committerMax Rees <maxcrees@me.com>2019-07-21 19:44:28 -0400
commitdb4d737a2d883f7d3ff122fa3116afecb9942770 (patch)
treea829de67577a3c8dac8386d902d25de634117e1a /user/libnl3
parent94731625b42d0dfc0fd5111482938584b40c7478 (diff)
downloadpackages-db4d737a2d883f7d3ff122fa3116afecb9942770.tar.gz
packages-db4d737a2d883f7d3ff122fa3116afecb9942770.tar.bz2
packages-db4d737a2d883f7d3ff122fa3116afecb9942770.tar.xz
packages-db4d737a2d883f7d3ff122fa3116afecb9942770.zip
user/*: APKBUILD bashism removal, part one (a-p)
Diffstat (limited to 'user/libnl3')
-rw-r--r--user/libnl3/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/user/libnl3/APKBUILD b/user/libnl3/APKBUILD
index 58dc88d4e..f5a2e5668 100644
--- a/user/libnl3/APKBUILD
+++ b/user/libnl3/APKBUILD
@@ -1,6 +1,7 @@
# Maintainer:
pkgname=libnl3
pkgver=3.2.28
+_pkgver=$(printf '%s' "$pkgver" | tr . _)
pkgrel=2
pkgdesc="Library for applications dealing with netlink sockets"
url="http://www.infradead.org/~tgr/libnl/"
@@ -10,8 +11,8 @@ depends=""
makedepends="linux-headers flex bison"
checkdepends="check-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-cli"
-source="https://github.com/thom311/libnl/releases/download/libnl${pkgver//./_}/libnl-$pkgver.tar.gz"
-builddir="$srcdir"/libnl-$pkgver
+source="https://github.com/thom311/libnl/releases/download/libnl$_pkgver/libnl-$pkgver.tar.gz"
+builddir="$srcdir/libnl-$pkgver"
build() {
cd "$builddir"