summaryrefslogtreecommitdiff
path: root/user/libreoffice/gettext-tiny.patch
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-08-19 03:38:17 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-08-19 03:38:17 +0000
commitcb6f083b369ee59de217c0504d471124d533325d (patch)
tree28e404754d754f3a852831d2b649010f70695e01 /user/libreoffice/gettext-tiny.patch
parent7ef2ed32d3d4442463f39d31380cff9432608231 (diff)
parentc5975fc819d7b79180a3627a87974da9d18685e3 (diff)
downloadpackages-cb6f083b369ee59de217c0504d471124d533325d.tar.gz
packages-cb6f083b369ee59de217c0504d471124d533325d.tar.bz2
packages-cb6f083b369ee59de217c0504d471124d533325d.tar.xz
packages-cb6f083b369ee59de217c0504d471124d533325d.zip
Merge branch 'libreoffice' into 'master'
LibreOffice and dependencies I have made a deal with Satan. See merge request !44
Diffstat (limited to 'user/libreoffice/gettext-tiny.patch')
-rw-r--r--user/libreoffice/gettext-tiny.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/libreoffice/gettext-tiny.patch b/user/libreoffice/gettext-tiny.patch
new file mode 100644
index 000000000..990241c3b
--- /dev/null
+++ b/user/libreoffice/gettext-tiny.patch
@@ -0,0 +1,38 @@
+gettext-tiny does not currently ship msguniq, so let's cheat around it
+
+--- libreoffice-6.0.6.2/solenv/gbuild/AllLangMoTarget.mk
++++ libreoffice-6.0.6.2/solenv/gbuild/AllLangMoTarget.mk
+@@ -40,10 +40,10 @@
+ $(call gb_Helper_abbreviate_dirs,\
+ mkdir -p $(dir $@) && \
+ if test -e $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po; then \
+- $(MSGUNIQ) --force-po $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po | $(MSGFMT) - -o $@; \
++ cat $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po | $(MSGFMT) - -o $@; \
+ else \
+ echo missing $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po && \
+- $(MSGUNIQ) --force-po $(SRCDIR)/solenv/bin/dummy.po | $(MSGFMT) - -o $@; \
++ cat $(SRCDIR)/solenv/bin/dummy.po | $(MSGFMT) - -o $@; \
+ fi)
+
+ #$(info $(call gb_MoTarget_get_target,$(1)))
+--- libreoffice-6.0.6.2/configure.ac
++++ libreoffice-6.0.6.2/configure.ac
+@@ -11749,18 +11749,6 @@
+ fi
+ fi
+ fi
+- if test -z "$MSGUNIQ"; then
+- if test -n "$LODE_HOME" -a -x "$LODE_HOME/opt/bin/msguniq" ; then
+- MSGUNIQ="$LODE_HOME/opt/bin/msguniq"
+- elif test -x "/opt/lo/bin/msguniq"; then
+- MSGUNIQ="/opt/lo/bin/msguniq"
+- else
+- AC_CHECK_PROGS(MSGUNIQ, [msguniq])
+- if test -z "$MSGUNIQ"; then
+- AC_MSG_ERROR([msguniq not found. Install GNU gettext, or re-run without languages.])
+- fi
+- fi
+- fi
+ fi
+ AC_SUBST(MSGFMT)
+ AC_SUBST(MSGUNIQ)