summaryrefslogtreecommitdiff
path: root/user/libreoffice/linux-musl.patch
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-08-19 03:38:17 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-08-19 03:38:17 +0000
commitcb6f083b369ee59de217c0504d471124d533325d (patch)
tree28e404754d754f3a852831d2b649010f70695e01 /user/libreoffice/linux-musl.patch
parent7ef2ed32d3d4442463f39d31380cff9432608231 (diff)
parentc5975fc819d7b79180a3627a87974da9d18685e3 (diff)
downloadpackages-cb6f083b369ee59de217c0504d471124d533325d.tar.gz
packages-cb6f083b369ee59de217c0504d471124d533325d.tar.bz2
packages-cb6f083b369ee59de217c0504d471124d533325d.tar.xz
packages-cb6f083b369ee59de217c0504d471124d533325d.zip
Merge branch 'libreoffice' into 'master'
LibreOffice and dependencies I have made a deal with Satan. See merge request !44
Diffstat (limited to 'user/libreoffice/linux-musl.patch')
-rw-r--r--user/libreoffice/linux-musl.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/user/libreoffice/linux-musl.patch b/user/libreoffice/linux-musl.patch
new file mode 100644
index 000000000..5fbf6b31c
--- /dev/null
+++ b/user/libreoffice/linux-musl.patch
@@ -0,0 +1,60 @@
+--- libreoffice-5.3.0.3/configure.ac.orig 2017-01-26 22:22:46.000000000 +0000
++++ libreoffice-5.3.0.3/configure.ac 2017-02-08 13:14:16.777547599 +0000
+@@ -652,7 +652,7 @@
+ fi
+ ;;
+
+-linux-gnu*|k*bsd*-gnu*)
++linux-gnu*|linux-musl*|k*bsd*-gnu*)
+ test_gtk=yes
+ build_gstreamer_1_0=yes
+ build_gstreamer_0_10=yes
+@@ -4170,7 +4170,7 @@
+ esac
+ ;;
+
+-linux-gnu*)
++linux-gnu*|linux-musl*)
+ COM=GCC
+ USING_X11=TRUE
+ OS=LINUX
+@@ -7197,7 +7197,7 @@
+ test -d "$JAVA_HOME/include/native_thread" && JAVAINC="$JAVAINC -I$JAVA_HOME/include/native_thread"
+ ;;
+
+- linux-gnu*)
++ linux-gnu*|linux-musl*)
+ JAVAINC="-I$JAVA_HOME/include"
+ JAVAINC="$JAVAINC -I$JAVA_HOME/include/linux"
+ test -d "$JAVA_HOME/include/native_thread" && JAVAINC="$JAVAINC -I$JAVA_HOME/include/native_thread"
+@@ -9748,21 +9748,6 @@
+ fi
+ AC_SUBST(SYSTEM_LIBEXTTEXTCAT_DATA)
+
+-dnl ***************************************
+-dnl testing libc version for Linux...
+-dnl ***************************************
+-if test "$_os" = "Linux"; then
+- AC_MSG_CHECKING([whether libc is >= 2.1.1])
+- exec 6>/dev/null # no output
+- AC_CHECK_LIB(c, gnu_get_libc_version, HAVE_LIBC=yes; export HAVE_LIBC)
+- exec 6>&1 # output on again
+- if test "$HAVE_LIBC"; then
+- AC_MSG_RESULT([yes])
+- else
+- AC_MSG_ERROR([no, upgrade libc])
+- fi
+-fi
+-
+ dnl =========================================
+ dnl Check for the Windows SDK.
+ dnl =========================================
+@@ -12775,7 +12760,7 @@
+
+ case "$host_os" in
+
+- aix*|dragonfly*|freebsd*|linux-gnu*|*netbsd*|openbsd*)
++ aix*|dragonfly*|freebsd*|linux-gnu*|linux-musl*|*netbsd*|openbsd*)
+ if test "$ENABLE_JAVA" != ""; then
+ pathmunge "$JAVA_HOME/bin" "after"
+ fi