summaryrefslogtreecommitdiff
path: root/user/libtirpc
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-29 19:32:52 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-29 19:33:10 +0000
commite0a676c728638a535ea80ae62ae5795fb0f6a706 (patch)
treebcbf634ff228513fc9cf7244da62eff1f2d2b03f /user/libtirpc
parent884687f4f8338adfbd4150afaad1f747f3b16797 (diff)
downloadpackages-e0a676c728638a535ea80ae62ae5795fb0f6a706.tar.gz
packages-e0a676c728638a535ea80ae62ae5795fb0f6a706.tar.bz2
packages-e0a676c728638a535ea80ae62ae5795fb0f6a706.tar.xz
packages-e0a676c728638a535ea80ae62ae5795fb0f6a706.zip
user/libtirpc: Bump to 1.2.5, fixes
* Define _BSD_SOURCE in <rpc/types.h> for building against in ISO C mode * Fix location of <endian.h> * Remove upstreamed musl compatibility patch.
Diffstat (limited to 'user/libtirpc')
-rw-r--r--user/libtirpc/APKBUILD16
-rw-r--r--user/libtirpc/bsd-types.patch12
-rw-r--r--user/libtirpc/endian-header.patch13
-rw-r--r--user/libtirpc/musl.patch11
4 files changed, 33 insertions, 19 deletions
diff --git a/user/libtirpc/APKBUILD b/user/libtirpc/APKBUILD
index 5231ff63d..e7322c37b 100644
--- a/user/libtirpc/APKBUILD
+++ b/user/libtirpc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libtirpc
-pkgver=1.1.4
-pkgrel=1
+pkgver=1.2.5
+pkgrel=0
pkgdesc="Transport Independent RPC library (SunRPC replacement)"
url="https://sourceforge.net/projects/libtirpc/"
arch="all"
@@ -12,11 +12,11 @@ depends_dev="bsd-compat-headers krb5-dev"
makedepends="$depends_dev autoconf automake libtool linux-headers"
subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg"
source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
- musl.patch"
+ bsd-types.patch
+ endian-header.patch
+ "
build() {
- cd "$builddir"
- export CFLAGS="$CFLAGS -D__u_char_defined -D__daddr_t_defined"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,9 +26,9 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="392f391f9fc1bd68d81dc44e4058831a64b32790b5c8c37338b0ab416fad2ae4d16389e632596734dba09780347918cc65c6f134e0c1afd09e81ec250785ed23 libtirpc-1.1.4.tar.bz2
-8e52246ae478ae9e4689426627e17d9c58d701f4fd21a40ffe3cf17c4ceaa4ab2e8e91d2fa3ba0d0c7adc52ae4b986fcda113ec86e370ede83903bb641de520c musl.patch"
+sha512sums="d31cd4e22301abe1baddd7e8f45aaaf056a40799e961646691d071084fed50563b5eecdd9b78062fe378be8db7a6d4b87597e21cb81ac925e447148684a2b002 libtirpc-1.2.5.tar.bz2
+237fd46e13bfce733023e425d561a43ef0a5dfd7f6fcdf1dd44d81a75cb08a7e2a4f80db313d145b45adf0f7f096cb7817786c5f73c0982b6ba34b3021b80d7c bsd-types.patch
+0a7a21a3d08bb0ff0110b993b8f8ddca41513ddaa0a468028a53eac9732a2a2e5070abe7da0a3ecff265b3800490c82f08810bd34e9d0af2e75345c86ef7d638 endian-header.patch"
diff --git a/user/libtirpc/bsd-types.patch b/user/libtirpc/bsd-types.patch
new file mode 100644
index 000000000..3fbe378b8
--- /dev/null
+++ b/user/libtirpc/bsd-types.patch
@@ -0,0 +1,12 @@
+u_int32_t (etc) is a BSD type. Define _BSD_SOURCE so musl declares it.
+
+--- libtirpc-1.2.5/tirpc/rpc/types.h.old 2019-12-19 18:55:48.000000000 +0000
++++ libtirpc-1.2.5/tirpc/rpc/types.h 2019-12-29 19:17:59.146261005 +0000
+@@ -38,6 +38,7 @@
+ #ifndef _TIRPC_TYPES_H
+ #define _TIRPC_TYPES_H
+
++#define _BSD_SOURCE
+ #include <sys/types.h>
+
+ typedef int32_t bool_t;
diff --git a/user/libtirpc/endian-header.patch b/user/libtirpc/endian-header.patch
new file mode 100644
index 000000000..9f9523305
--- /dev/null
+++ b/user/libtirpc/endian-header.patch
@@ -0,0 +1,13 @@
+Fix location of endian.h. Yay for POSIX next.
+
+--- libtirpc-1.2.5/src/xdr_float.c.old 2019-12-19 18:55:48.000000000 +0000
++++ libtirpc-1.2.5/src/xdr_float.c 2019-12-29 18:54:28.408092748 +0000
+@@ -83,7 +83,7 @@
+ };
+ #else
+
+-#include <bits/endian.h>
++#include <endian.h>
+ #define IEEEFP
+
+ #endif /* vax */
diff --git a/user/libtirpc/musl.patch b/user/libtirpc/musl.patch
deleted file mode 100644
index 5a4fb04f5..000000000
--- a/user/libtirpc/musl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./tirpc/rpc/types.h.orig 2018-03-17 10:23:10.022055255 +0100
-+++ ./tirpc/rpc/types.h 2018-03-17 10:23:30.877751656 +0100
-@@ -66,7 +66,7 @@
- #define mem_free(ptr, bsize) free(ptr)
-
-
--#if defined __APPLE_CC__ || defined __FreeBSD__
-+#if defined __APPLE_CC__ || defined __FreeBSD__ || !defined(__GLIBC__)
- # define __u_char_defined
- # define __daddr_t_defined
- #endif