summaryrefslogtreecommitdiff
path: root/user/libutempter/fix-linking.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-29 14:56:44 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-29 14:56:44 +0000
commit874e95bb992191beef16484b20a7ddca5e72dd20 (patch)
treede84c848fcd447c2c61962eb310eda03881126e2 /user/libutempter/fix-linking.patch
parentb66a3d7f8ada41322c86651edfbae5d763391368 (diff)
downloadpackages-874e95bb992191beef16484b20a7ddca5e72dd20.tar.gz
packages-874e95bb992191beef16484b20a7ddca5e72dd20.tar.bz2
packages-874e95bb992191beef16484b20a7ddca5e72dd20.tar.xz
packages-874e95bb992191beef16484b20a7ddca5e72dd20.zip
user/libutempter: actually make the library work
Diffstat (limited to 'user/libutempter/fix-linking.patch')
-rw-r--r--user/libutempter/fix-linking.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/user/libutempter/fix-linking.patch b/user/libutempter/fix-linking.patch
new file mode 100644
index 000000000..91719507a
--- /dev/null
+++ b/user/libutempter/fix-linking.patch
@@ -0,0 +1,11 @@
+--- libutempter-1.1.6/Makefile.old 2010-11-04 17:14:53.000000000 +0000
++++ libutempter-1.1.6/Makefile 2018-08-29 14:47:24.740000000 +0000
+@@ -52,7 +52,7 @@
+ $(COMPILE.c) -fPIC $< $(OUTPUT_OPTION)
+
+ $(PROJECT): utempter.c
+- $(LINK.c) -Wl,-z,now,-stats $(LDLIBS) $< $(OUTPUT_OPTION)
++ $(LINK.c) -Wl,-z,now,-stats $< $(OUTPUT_OPTION) $(LDLIBS)
+
+ $(SHAREDLIB): iface.os $(MAP)
+ $(LINK.o) -shared \