summaryrefslogtreecommitdiff
path: root/user/libva
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-26 09:14:33 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-29 04:55:41 -0600
commitcdc0a11a7da0498de5932c125c239d57ae345709 (patch)
tree4a296ffe9bcd54e74bdf3ff8fc55b60c77f77307 /user/libva
parent99487e2589a2694f7d9517942e93fce7036e4b92 (diff)
downloadpackages-cdc0a11a7da0498de5932c125c239d57ae345709.tar.gz
packages-cdc0a11a7da0498de5932c125c239d57ae345709.tar.bz2
packages-cdc0a11a7da0498de5932c125c239d57ae345709.tar.xz
packages-cdc0a11a7da0498de5932c125c239d57ae345709.zip
user/libva: Add Wayland support, split by winsys
These automatically add themselves when the winsys itself is present (libx11 or wayland), so there should be no functional change for users.
Diffstat (limited to 'user/libva')
-rw-r--r--user/libva/APKBUILD24
1 files changed, 20 insertions, 4 deletions
diff --git a/user/libva/APKBUILD b/user/libva/APKBUILD
index e3316c58e..a772ea14e 100644
--- a/user/libva/APKBUILD
+++ b/user/libva/APKBUILD
@@ -2,15 +2,16 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libva
pkgver=2.14.0
-pkgrel=0
+pkgrel=1
pkgdesc="Video Acceleration (VA) API for Linux"
url="https://github.com/intel/libva"
arch="all"
options="!check" # No test suite.
license="MIT"
depends=""
-makedepends="libdrm-dev libx11-dev libxext-dev libxfixes-dev cmd:which"
-subpackages="$pkgname-dev"
+makedepends="libdrm-dev libx11-dev libxext-dev libxfixes-dev cmd:which
+ wayland-dev wayland-protocols"
+subpackages="$pkgname-dev $pkgname-wayland $pkgname-x11"
source="https://github.com/intel/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2"
build() {
@@ -23,7 +24,7 @@ build() {
--infodir=/usr/share/info \
--localstatedir=/var \
--enable-x11 \
- --disable-wayland \
+ --enable-wayland \
--disable-static \
--enable-shared
make
@@ -33,4 +34,19 @@ package() {
make DESTDIR="$pkgdir" install
}
+wayland() {
+ pkgdesc="$pkgdesc (Wayland library)"
+ install_if="$pkgname=$pkgver-r$pkgrel wayland"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libva-wayland.so* "$subpkgdir"/usr/lib/
+}
+
+x11() {
+ pkgdesc="$pkgdesc (X11 library)"
+ install_if="$pkgname=$pkgver-r$pkgrel libx11"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libva-glx.so* "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/libva-x11.so* "$subpkgdir"/usr/lib/
+}
+
sha512sums="7ee6f0711929d1c6f6436b69ad0fedcee7e8a450be907d90a7c9741d55de824de471efbc20a398a47af03f5bbacb927daa1f2f780fce6ddfe6bbee21729c95ca libva-2.14.0.tar.bz2"