summaryrefslogtreecommitdiff
path: root/user/libvdpau
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-08 18:51:29 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-08 18:51:29 -0500
commit6ee22c1e379ef5bdb4b797feef87c4b4e1b29ab7 (patch)
treefa2169d0244e725b0128911a097518824fcfc9f9 /user/libvdpau
parentec268aa29d339098cbdde574541c381da8254e9a (diff)
downloadpackages-6ee22c1e379ef5bdb4b797feef87c4b4e1b29ab7.tar.gz
packages-6ee22c1e379ef5bdb4b797feef87c4b4e1b29ab7.tar.bz2
packages-6ee22c1e379ef5bdb4b797feef87c4b4e1b29ab7.tar.xz
packages-6ee22c1e379ef5bdb4b797feef87c4b4e1b29ab7.zip
user/libvdpau: pull in, take, fix
Diffstat (limited to 'user/libvdpau')
-rw-r--r--user/libvdpau/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/user/libvdpau/APKBUILD b/user/libvdpau/APKBUILD
new file mode 100644
index 000000000..a8febe21a
--- /dev/null
+++ b/user/libvdpau/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Carlo Landmeter
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libvdpau
+pkgver=1.1.1
+pkgrel=2
+pkgdesc="Hardware-accelerated video playback library"
+url="https://cgit.freedesktop.org/~aplattner/libvdpau"
+arch="all"
+license="MIT"
+depends=
+makedepends="libx11-dev libxext-dev xorgproto-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://people.freedesktop.org/~aplattner/vdpau/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "$builddir"
+ LIBS="-lX11" \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+sha512sums="e094494fc820c2395c9dbb4e69daa89334b9186e2ad1a6c06671c7f844568db191ce4d1d9df95c4536579864bcc8541eb6fd159c377bc73c228cdf2a0fea50fb libvdpau-1.1.1.tar.gz"