summaryrefslogtreecommitdiff
path: root/user/libvisio/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-08-19 03:38:17 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-08-19 03:38:17 +0000
commitcb6f083b369ee59de217c0504d471124d533325d (patch)
tree28e404754d754f3a852831d2b649010f70695e01 /user/libvisio/APKBUILD
parent7ef2ed32d3d4442463f39d31380cff9432608231 (diff)
parentc5975fc819d7b79180a3627a87974da9d18685e3 (diff)
downloadpackages-cb6f083b369ee59de217c0504d471124d533325d.tar.gz
packages-cb6f083b369ee59de217c0504d471124d533325d.tar.bz2
packages-cb6f083b369ee59de217c0504d471124d533325d.tar.xz
packages-cb6f083b369ee59de217c0504d471124d533325d.zip
Merge branch 'libreoffice' into 'master'
LibreOffice and dependencies I have made a deal with Satan. See merge request !44
Diffstat (limited to 'user/libvisio/APKBUILD')
-rw-r--r--user/libvisio/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/user/libvisio/APKBUILD b/user/libvisio/APKBUILD
new file mode 100644
index 000000000..84a23c799
--- /dev/null
+++ b/user/libvisio/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=libvisio
+pkgver=0.1.6
+pkgrel=2
+pkgdesc="Import filter and tools for MS Visio diagrams"
+url="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
+arch="all"
+license="MPL-2.0"
+depends_dev="librevenge-dev"
+makedepends="$depends_dev boost-dev icu-dev libxml2-dev doxygen gperf perl"
+checkdepends="cppunit-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+tools() {
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+sha512sums="58cee8cfe4205b2cad2f11dbe17882e57ebf0d10500116ca9d8d120e138f8eb0c65a5fea3bd7d2746bf8140377ee9deb34258597e028f9fdc8d21f270606cce1 libvisio-0.1.6.tar.xz"