summaryrefslogtreecommitdiff
path: root/user/libvncserver
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-15 23:46:58 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-15 23:46:58 -0500
commit26af5fd84f412b1311deb2fcba051d2068b974e0 (patch)
treebd7e631f50cd2922c9c4680233e55e8da4aa93e8 /user/libvncserver
parent5a7a61916e6c530871467e9aecee5985f2e415a8 (diff)
downloadpackages-26af5fd84f412b1311deb2fcba051d2068b974e0.tar.gz
packages-26af5fd84f412b1311deb2fcba051d2068b974e0.tar.bz2
packages-26af5fd84f412b1311deb2fcba051d2068b974e0.tar.xz
packages-26af5fd84f412b1311deb2fcba051d2068b974e0.zip
user/libvncserver: pull in, fix up
Diffstat (limited to 'user/libvncserver')
-rw-r--r--user/libvncserver/APKBUILD53
-rw-r--r--user/libvncserver/LibVNCServer-0.9.10-system_minilzo.patch67
2 files changed, 120 insertions, 0 deletions
diff --git a/user/libvncserver/APKBUILD b/user/libvncserver/APKBUILD
new file mode 100644
index 000000000..324da7fcb
--- /dev/null
+++ b/user/libvncserver/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Sergei Lukin <sergej.lukin@gmail.com>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libvncserver
+pkgver=0.9.11
+pkgrel=1
+pkgdesc="Library to make writing a vnc server easy"
+url="https://libvnc.github.io/"
+arch="all"
+license="GPL-2.0+"
+depends=""
+depends_dev="libgcrypt-dev libjpeg-turbo-dev gnutls-dev libpng-dev
+ libice-dev libx11-dev libxdamage-dev libxext-dev libxfixes-dev
+ libxi-dev libxinerama-dev libxrandr-dev libxtst-dev"
+makedepends="$depends_dev autoconf automake libtool"
+subpackages="$pkgname-dev"
+source="https://github.com/LibVNC/libvncserver/archive/LibVNCServer-$pkgver.tar.gz
+ "
+builddir="$srcdir"/libvncserver-LibVNCServer-$pkgver
+
+# secfixes:
+# 0.9.11-r0:
+# - CVE-2016-9941
+# - CVE-2016-9942
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ ./autogen.sh
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+ test/tjunittest
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="e473c081b68dd3cdd96a1756b4f4945ece79d3c8e4cef62140be1699671555fc16d3080e81d764197a14ea83203ffcd0e18c3cc182e012d036e3faae943003fb LibVNCServer-0.9.11.tar.gz"
diff --git a/user/libvncserver/LibVNCServer-0.9.10-system_minilzo.patch b/user/libvncserver/LibVNCServer-0.9.10-system_minilzo.patch
new file mode 100644
index 000000000..34e789bba
--- /dev/null
+++ b/user/libvncserver/LibVNCServer-0.9.10-system_minilzo.patch
@@ -0,0 +1,67 @@
+diff -up LibVNCServer-0.9.10/libvncclient/Makefile.am.system_minilzo LibVNCServer-0.9.10/libvncclient/Makefile.am
+--- LibVNCServer-0.9.10/libvncclient/Makefile.am.system_minilzo 2014-04-05 18:38:35.000000000 -0500
++++ LibVNCServer-0.9.10/libvncclient/Makefile.am 2014-04-29 08:56:27.861761880 -0500
+@@ -13,10 +13,10 @@ endif
+ endif
+
+
+-libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c ../common/minilzo.c $(TLSSRCS)
+-libvncclient_la_LIBADD=$(TLSLIBS) $(VA_LIBS)
++libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c $(TLSSRCS)
++libvncclient_la_LIBADD=$(TLSLIBS) $(VA_LIBS) -lminilzo
+
+-noinst_HEADERS=../common/lzodefs.h ../common/lzoconf.h ../common/minilzo.h tls.h
++noinst_HEADERS=tls.h
+
+ rfbproto.o: rfbproto.c corre.c hextile.c rre.c tight.c zlib.c zrle.c ultra.c
+
+diff -up LibVNCServer-0.9.10/libvncclient/rfbproto.c.system_minilzo LibVNCServer-0.9.10/libvncclient/rfbproto.c
+--- LibVNCServer-0.9.10/libvncclient/rfbproto.c.system_minilzo 2014-04-05 18:38:35.000000000 -0500
++++ LibVNCServer-0.9.10/libvncclient/rfbproto.c 2014-04-29 08:39:57.638331693 -0500
+@@ -61,7 +61,7 @@
+ #include <gcrypt.h>
+ #endif
+
+-#include "minilzo.h"
++#include <lzo/minilzo.h>
+ #include "tls.h"
+
+ /*
+diff -up LibVNCServer-0.9.10/libvncserver/Makefile.am.system_minilzo LibVNCServer-0.9.10/libvncserver/Makefile.am
+--- LibVNCServer-0.9.10/libvncserver/Makefile.am.system_minilzo 2014-04-05 18:38:35.000000000 -0500
++++ LibVNCServer-0.9.10/libvncserver/Makefile.am 2014-04-29 08:39:57.638331693 -0500
+@@ -37,7 +37,7 @@ include_HEADERS=../rfb/rfb.h ../rfb/rfbc
+
+ noinst_HEADERS=../common/d3des.h ../rfb/default8x16.h zrleoutstream.h \
+ zrlepalettehelper.h zrletypes.h private.h scale.h rfbssl.h rfbcrypto.h \
+- ../common/minilzo.h ../common/lzoconf.h ../common/lzodefs.h ../common/md5.h ../common/sha1.h \
++ ../common/md5.h ../common/sha1.h \
+ $(TIGHTVNCFILETRANSFERHDRS)
+
+ EXTRA_DIST=tableinit24.c tableinittctemplate.c tabletranstemplate.c \
+@@ -54,11 +54,11 @@ endif
+ LIB_SRCS = main.c rfbserver.c rfbregion.c auth.c sockets.c $(WEBSOCKETSSRCS) \
+ stats.c corre.c hextile.c rre.c translate.c cutpaste.c \
+ httpd.c cursor.c font.c \
+- draw.c selbox.c ../common/d3des.c ../common/vncauth.c cargs.c ../common/minilzo.c ultra.c scale.c \
++ draw.c selbox.c ../common/d3des.c ../common/vncauth.c cargs.c ultra.c scale.c \
+ $(ZLIBSRCS) $(TIGHTSRCS) $(TIGHTVNCFILETRANSFERSRCS)
+
+ libvncserver_la_SOURCES=$(LIB_SRCS)
+-libvncserver_la_LIBADD=$(WEBSOCKETSSSLLIBS)
++libvncserver_la_LIBADD=$(WEBSOCKETSSSLLIBS) -lminilzo
+
+ lib_LTLIBRARIES=libvncserver.la
+
+diff -up LibVNCServer-0.9.10/libvncserver/ultra.c.system_minilzo LibVNCServer-0.9.10/libvncserver/ultra.c
+--- LibVNCServer-0.9.10/libvncserver/ultra.c.system_minilzo 2014-04-05 18:38:35.000000000 -0500
++++ LibVNCServer-0.9.10/libvncserver/ultra.c 2014-04-29 08:39:57.638331693 -0500
+@@ -8,7 +8,7 @@
+ */
+
+ #include <rfb/rfb.h>
+-#include "minilzo.h"
++#include <lzo/minilzo.h>
+
+ /*
+ * cl->beforeEncBuf contains pixel data in the client's format.