summaryrefslogtreecommitdiff
path: root/user/libwacom/musl-test.patch
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/libwacom/musl-test.patch
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/libwacom/musl-test.patch')
-rw-r--r--user/libwacom/musl-test.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/user/libwacom/musl-test.patch b/user/libwacom/musl-test.patch
new file mode 100644
index 000000000..74625f02b
--- /dev/null
+++ b/user/libwacom/musl-test.patch
@@ -0,0 +1,22 @@
+--- libwacom-1.2/meson.build.old 2019-12-22 21:45:06.000000000 +0000
++++ libwacom-1.2/meson.build 2019-12-25 11:43:51.004107631 +0000
+@@ -555,7 +555,7 @@
+ # because of the tricks we use in calling the function and exposing
+ # it to begin with, LTO gets confused and this fails to link.
+ # Let's just disable it here.
+- if not get_option('b_lto')
++ if not get_option('b_lto') and get_option('test_deprecated')
+ test_deprecated = executable('test-deprecated',
+ 'test/test-deprecated.c',
+ dependencies: [dep_libwacom, dep_dl],
+--- libwacom-1.2/meson_options.txt.old 2019-11-07 02:25:47.000000000 +0000
++++ libwacom-1.2/meson_options.txt 2019-12-25 11:45:11.585452086 +0000
+@@ -10,4 +10,8 @@
+ type: 'boolean',
+ value: true,
+ description: 'Build the tests [default=true]')
++option('test_deprecated',
++ type: 'boolean',
++ value: true,
++ description: 'Test the deprecated ABI (fails on musl) [default=true]')
+