summaryrefslogtreecommitdiff
path: root/user/libxcb
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-23 22:06:27 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-23 22:06:39 -0600
commita03cc5caa52177f93d36ddd3d0118325c99e156d (patch)
tree15868be01f3993a9d6d811efcb5688cf12685a55 /user/libxcb
parent478dc22a4cb42e63d7518b71fd74cf93b558b58c (diff)
downloadpackages-a03cc5caa52177f93d36ddd3d0118325c99e156d.tar.gz
packages-a03cc5caa52177f93d36ddd3d0118325c99e156d.tar.bz2
packages-a03cc5caa52177f93d36ddd3d0118325c99e156d.tar.xz
packages-a03cc5caa52177f93d36ddd3d0118325c99e156d.zip
user/X11 stuff: minor fixes
Ensure modern syntax, don't install COPYING for typical licenses, etc. For libxcb, ensure test suite works with new version of system/check. Upstreamed at: https://gitlab.freedesktop.org/xorg/lib/libxcb/merge_requests/6
Diffstat (limited to 'user/libxcb')
-rw-r--r--user/libxcb/0001-tests-Support-Check-0.13.0-API.patch40
-rw-r--r--user/libxcb/APKBUILD14
2 files changed, 46 insertions, 8 deletions
diff --git a/user/libxcb/0001-tests-Support-Check-0.13.0-API.patch b/user/libxcb/0001-tests-Support-Check-0.13.0-API.patch
new file mode 100644
index 000000000..fce1f83d0
--- /dev/null
+++ b/user/libxcb/0001-tests-Support-Check-0.13.0-API.patch
@@ -0,0 +1,40 @@
+From a667ec3e0cf5d9cd1d1715e3fff3328e353fae84 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Mon, 23 Dec 2019 21:49:29 -0600
+Subject: [PATCH] tests: Support Check 0.13.0 API
+
+---
+ tests/check_all.c | 4 ++--
+ tests/check_suites.h | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tests/check_all.c b/tests/check_all.c
+index 4393422..f201dec 100644
+--- a/tests/check_all.c
++++ b/tests/check_all.c
+@@ -1,10 +1,10 @@
+ #include <stdlib.h>
+ #include "check_suites.h"
+
+-void suite_add_test(Suite *s, TFun tf, const char *name)
++void suite_add_test(Suite *s, const TTest *tt, const char *name)
+ {
+ TCase *tc = tcase_create(name);
+- tcase_add_test(tc, tf);
++ tcase_add_test(tc, tt);
+ suite_add_tcase(s, tc);
+ }
+
+diff --git a/tests/check_suites.h b/tests/check_suites.h
+index 499f1af..595923a 100644
+--- a/tests/check_suites.h
++++ b/tests/check_suites.h
+@@ -1,4 +1,4 @@
+ #include <check.h>
+
+-void suite_add_test(Suite *s, TFun tf, const char *name);
++void suite_add_test(Suite *s, const TTest *tt, const char *name);
+ Suite *public_suite(void);
+--
+2.24.1
+
diff --git a/user/libxcb/APKBUILD b/user/libxcb/APKBUILD
index 53db51310..ddeb95531 100644
--- a/user/libxcb/APKBUILD
+++ b/user/libxcb/APKBUILD
@@ -1,20 +1,20 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libxcb
pkgver=1.13.1
-pkgrel=0
+pkgrel=1
pkgdesc="X11 C language Binding"
url="https://xcb.freedesktop.org/"
arch="all"
license="X11"
depends=""
-subpackages="$pkgname-dev $pkgname-doc"
depends_dev="libxau-dev xcb-proto"
checkdepends="check-dev"
+subpackages="$pkgname-dev $pkgname-doc"
makedepends="$depends_dev libxslt python3 libpthread-stubs libxdmcp-dev"
-source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
+source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2
+ 0001-tests-Support-Check-0.13.0-API.patch"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,14 +27,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="763edff9572623674f75a858adc57b5c09591f508cc5d5093218e7bb047abdbe0a0108bd465419a8bf15c7dcdc85efdd2d4d9fd56605c41475d15dc992640c23 libxcb-1.13.1.tar.bz2"
+sha512sums="763edff9572623674f75a858adc57b5c09591f508cc5d5093218e7bb047abdbe0a0108bd465419a8bf15c7dcdc85efdd2d4d9fd56605c41475d15dc992640c23 libxcb-1.13.1.tar.bz2
+c5731fc76566f9f27d6d6f762971e07d2c27ed34a4881b8fa03c332f2d6a163954efb658682043e181170b93d3c979fa2c2374d3b25c80eead5747dea684037a 0001-tests-Support-Check-0.13.0-API.patch"