summaryrefslogtreecommitdiff
path: root/user/lighttpd
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-28 02:12:46 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-28 02:12:46 +0000
commit0824488ffbc2f59d417ffc91492f789d7c7b7c06 (patch)
treed52344a483d4b05d4f12d6ccf41f57b738dda2d4 /user/lighttpd
parent54fb0bf199ac8cc1c0b831c87359a505b8e8231a (diff)
downloadpackages-0824488ffbc2f59d417ffc91492f789d7c7b7c06.tar.gz
packages-0824488ffbc2f59d417ffc91492f789d7c7b7c06.tar.bz2
packages-0824488ffbc2f59d417ffc91492f789d7c7b7c06.tar.xz
packages-0824488ffbc2f59d417ffc91492f789d7c7b7c06.zip
user/lighttpd: finally fix user addition
Diffstat (limited to 'user/lighttpd')
-rw-r--r--user/lighttpd/APKBUILD7
-rw-r--r--user/lighttpd/lighttpd.pre-install6
2 files changed, 4 insertions, 9 deletions
diff --git a/user/lighttpd/APKBUILD b/user/lighttpd/APKBUILD
index 6a6420b06..5f768bbdd 100644
--- a/user/lighttpd/APKBUILD
+++ b/user/lighttpd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=lighttpd
pkgver=1.4.54
-pkgrel=1
+pkgrel=2
pkgdesc="A secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
arch="all"
@@ -26,8 +26,6 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
"
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -49,13 +47,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
# create dirs
diff --git a/user/lighttpd/lighttpd.pre-install b/user/lighttpd/lighttpd.pre-install
index bdc9b91b6..3d6124de0 100644
--- a/user/lighttpd/lighttpd.pre-install
+++ b/user/lighttpd/lighttpd.pre-install
@@ -1,8 +1,8 @@
#!/bin/sh
groupadd -r -g 82 www-data 2>/dev/null
-groupadd -S lighttpd 2>/dev/null
-useradd -c lighttpd -s /sbin/nologin -g -G www-data \
- lighttpd -m -d /var/www/localhost/htdocs -k /etc/skel -r lighttpd 2>/dev/null
+groupadd -r lighttpd 2>/dev/null
+useradd -c lighttpd -s /sbin/nologin -G www-data \
+ -d /var/www/localhost/htdocs -r lighttpd 2>/dev/null
exit 0