summaryrefslogtreecommitdiff
path: root/user/lighttpd
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-07-22 02:13:03 -0400
committerMax Rees <maxcrees@me.com>2019-07-22 02:13:03 -0400
commit93b0513be9422e1666163d89031419412866e370 (patch)
tree8dfdcd50eb8b758584387bd0511968294118119a /user/lighttpd
parente144e346b829eb39c1d2c82f5bdc4f8d991624b7 (diff)
downloadpackages-93b0513be9422e1666163d89031419412866e370.tar.gz
packages-93b0513be9422e1666163d89031419412866e370.tar.bz2
packages-93b0513be9422e1666163d89031419412866e370.tar.xz
packages-93b0513be9422e1666163d89031419412866e370.zip
user/*: use useradd, groupadd instead of adduser, addgroup
Diffstat (limited to 'user/lighttpd')
-rw-r--r--user/lighttpd/APKBUILD2
-rw-r--r--user/lighttpd/lighttpd.pre-install8
2 files changed, 5 insertions, 5 deletions
diff --git a/user/lighttpd/APKBUILD b/user/lighttpd/APKBUILD
index 113d84c04..6a6420b06 100644
--- a/user/lighttpd/APKBUILD
+++ b/user/lighttpd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=lighttpd
pkgver=1.4.54
-pkgrel=0
+pkgrel=1
pkgdesc="A secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
arch="all"
diff --git a/user/lighttpd/lighttpd.pre-install b/user/lighttpd/lighttpd.pre-install
index 81ccda1f9..bdc9b91b6 100644
--- a/user/lighttpd/lighttpd.pre-install
+++ b/user/lighttpd/lighttpd.pre-install
@@ -1,8 +1,8 @@
#!/bin/sh
-addgroup -S -g 82 www-data 2>/dev/null
-addgroup -S lighttpd 2>/dev/null
-adduser -S -D -H -h /var/www/localhost/htdocs -s /sbin/nologin -G lighttpd -g lighttpd lighttpd 2>/dev/null
-addgroup lighttpd www-data 2>/dev/null
+groupadd -r -g 82 www-data 2>/dev/null
+groupadd -S lighttpd 2>/dev/null
+useradd -c lighttpd -s /sbin/nologin -g -G www-data \
+ lighttpd -m -d /var/www/localhost/htdocs -k /etc/skel -r lighttpd 2>/dev/null
exit 0