summaryrefslogtreecommitdiff
path: root/user/lxqt-qtplugin
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-06-06 12:52:39 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-06-06 12:52:39 -0500
commitcf99bce644f7a2811b2af2111ce3eefc03d3a56e (patch)
tree379e470a200eb163bad6939c4c7a4d59945cf5cc /user/lxqt-qtplugin
parentf8cfe5235d46a6a04de030800298410d7a5bd73f (diff)
downloadpackages-cf99bce644f7a2811b2af2111ce3eefc03d3a56e.tar.gz
packages-cf99bce644f7a2811b2af2111ce3eefc03d3a56e.tar.bz2
packages-cf99bce644f7a2811b2af2111ce3eefc03d3a56e.tar.xz
packages-cf99bce644f7a2811b2af2111ce3eefc03d3a56e.zip
user/lxqt-qtplugin: bump to 0.13.0
Diffstat (limited to 'user/lxqt-qtplugin')
-rw-r--r--user/lxqt-qtplugin/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/user/lxqt-qtplugin/APKBUILD b/user/lxqt-qtplugin/APKBUILD
index 789ea58df..64e463cbf 100644
--- a/user/lxqt-qtplugin/APKBUILD
+++ b/user/lxqt-qtplugin/APKBUILD
@@ -1,17 +1,17 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=lxqt-qtplugin
-pkgver=0.12.0
+pkgver=0.13.0
pkgrel=0
pkgdesc="Qt plugin for platform integration with LXQt"
url="http://lxqt.org"
arch="all"
license="LGPL-2.1+"
depends=""
-makedepends="cmake extra-cmake-modules lxqt-build-tools libdbusmenu-qt-dev liblxqt-dev libfm-qt-dev qt5-qttools-dev"
+makedepends="cmake extra-cmake-modules lxqt-build-tools>=0.5.0 libdbusmenu-qt-dev liblxqt-dev libfm-qt-dev qt5-qttools-dev"
install=""
subpackages=""
-source="https://github.com/lxde/lxqt-qtplugin/releases/download/$pkgver/lxqt-qtplugin-$pkgver.tar.xz"
+source="https://github.com/lxqt/lxqt-qtplugin/releases/download/$pkgver/lxqt-qtplugin-$pkgver.tar.xz"
builddir="$srcdir/lxqt-qtplugin-$pkgver"
build() {
@@ -19,6 +19,7 @@ build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
+ mkdir -p build && cd build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -27,18 +28,18 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DPULL_TRANSLATIONS=False \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} ..
make
}
check() {
- cd "$builddir"
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
+ cd "$builddir"/build
make DESTDIR="$pkgdir" install
}
-sha512sums="ea060e600ab5c19e43bcbf77c17797f77050fbd7a532b7ff3fa3d77005064c59b0e553f3dd6819ca4206056af709cea9a8ad892c37454191f6f9ddc509f3f119 lxqt-qtplugin-0.12.0.tar.xz"
+sha512sums="22f059accdca8216b80af8773eab462c779c489575aa7802e82bb95da4f22a9a0d5a1234b2da4cb39c5050a6e9ded3c2b977068cc37af356ecb09e364633c7d6 lxqt-qtplugin-0.13.0.tar.xz"