summaryrefslogtreecommitdiff
path: root/user/mac-fdisk
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-12-17 20:49:14 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-12-17 20:49:14 -0600
commit656ae6bf9f8a64aee95c4797b20bfe713627f1f4 (patch)
tree366e9d652b612699a1dbc2cc06d489badb346985 /user/mac-fdisk
parent68d3758eaa1d21de0b83304ecdef74546d7af594 (diff)
downloadpackages-656ae6bf9f8a64aee95c4797b20bfe713627f1f4.tar.gz
packages-656ae6bf9f8a64aee95c4797b20bfe713627f1f4.tar.bz2
packages-656ae6bf9f8a64aee95c4797b20bfe713627f1f4.tar.xz
packages-656ae6bf9f8a64aee95c4797b20bfe713627f1f4.zip
user/mac-fdisk: possible fix for #39
Diffstat (limited to 'user/mac-fdisk')
-rw-r--r--user/mac-fdisk/APKBUILD8
-rw-r--r--user/mac-fdisk/flush-stdout.patch59
2 files changed, 64 insertions, 3 deletions
diff --git a/user/mac-fdisk/APKBUILD b/user/mac-fdisk/APKBUILD
index 213f1b7b9..24d668c07 100644
--- a/user/mac-fdisk/APKBUILD
+++ b/user/mac-fdisk/APKBUILD
@@ -3,7 +3,7 @@
pkgname=mac-fdisk
pkgver=0.1.16
_pkgver=0.1
-pkgrel=0
+pkgrel=1
pkgdesc="68K and PowerPC fixed disk partitioning utility"
url="https://adelielinux.org/"
arch="all"
@@ -21,7 +21,8 @@ source="https://distfiles.adelielinux.org/source/mac-fdisk_0.1.orig.tar.gz
mac-fdisk-fdisk-header-musl.patch
mac-fdisk-large-disk-support.patch
mac-fdisk-largerthan2gb.patch
- mac-fdisk-non-glibc-support.patch"
+ mac-fdisk-non-glibc-support.patch
+ flush-stdout.patch"
builddir="$srcdir/$pkgname-$_pkgver.orig"
build() {
@@ -49,4 +50,5 @@ e521009d628934fe3925085c941d2bb3fba9c3322ccaaa6dd650ecbc6b990056f9bf186adb3a645d
d558d66fb91d845e09cca7c3832d2ec078581ed09574fb38d9476f0417901794ae70e4a284379977a5c50599ce9570da8359e321de91f9f77263601c090e501d mac-fdisk-fdisk-header-musl.patch
c9abc952f1ce618b085a134145fa99efa9c10b55f3fa773fb6b74a66468537bc3567ec632fe6e464c5158383135c858c171d8d94d7142d38beff39a17e31187a mac-fdisk-large-disk-support.patch
b5988eb6aa64324421398461396b0fdd0b55d7643094c042bea7264ec0f9913e8a793f3f550c15928419e697a14f2932f483c4b98a54618af99b35aa7ceae757 mac-fdisk-largerthan2gb.patch
-f9d988ae693707b7b9bcf3cbaba4f65d1337c85e733209b146154bca4246021d2277824cc4766d66e9594d9fac49c0c0216f14c24511b6ad5104ac0833d9975b mac-fdisk-non-glibc-support.patch"
+f9d988ae693707b7b9bcf3cbaba4f65d1337c85e733209b146154bca4246021d2277824cc4766d66e9594d9fac49c0c0216f14c24511b6ad5104ac0833d9975b mac-fdisk-non-glibc-support.patch
+e036a8b3538550fcc55b8e2a4dd1d53f035f4c43f5aa919fde51df4f8431f5f2b3b4b9b6b6b589adf575b4b012ce48d55430cf2fd47e14d57182ff3ddb443ecd flush-stdout.patch"
diff --git a/user/mac-fdisk/flush-stdout.patch b/user/mac-fdisk/flush-stdout.patch
new file mode 100644
index 000000000..a4a1c69ba
--- /dev/null
+++ b/user/mac-fdisk/flush-stdout.patch
@@ -0,0 +1,59 @@
+--- mac-fdisk-0.1.orig/io.c.old 2017-12-17 20:36:23.277115889 -0600
++++ mac-fdisk-0.1.orig/io.c 2017-12-17 20:46:59.295011785 -0600
+@@ -148,6 +148,7 @@
+
+ flush_to_newline(0);
+ printf(prompt);
++ fflush(stdout);
+
+ for (;;) {
+ c = getch();
+@@ -166,6 +167,7 @@
+ } else {
+ flush_to_newline(0);
+ printf(prompt);
++ fflush(stdout);
+ }
+ }
+ return -1;
+@@ -179,6 +181,7 @@
+
+ if (promptBeforeGet) {
+ printf(prompt);
++ fflush(stdout);
+ }
+ for (;;) {
+ c = getch();
+@@ -189,6 +192,7 @@
+ // skip blanks and tabs
+ } else if (c == '\n') {
+ printf(prompt);
++ fflush(stdout);
+ } else {
+ *command = c;
+ return 1;
+@@ -214,6 +218,7 @@
+ } else if (c == '\n') {
+ if (default_value < 0) {
+ printf(prompt);
++ fflush(stdout);
+ } else {
+ ungetch(c);
+ *number = default_value;
+@@ -292,6 +297,7 @@
+ } else if (c == '\n') {
+ if (reprompt) {
+ printf(prompt);
++ fflush(stdout);
+ } else {
+ ungetch(c);
+ *string = NULL;
+@@ -466,7 +472,7 @@
+ long t;
+
+ if (rflag) {
+- printf("Can't write block %u to file", (unsigned int)num);
++ printf("Can't write block %u to file\n", (unsigned int)num);
+ return 0;
+ }
+ #ifndef __linux__