summaryrefslogtreecommitdiff
path: root/user/marco
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-03-23 06:05:29 -0500
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-03-23 06:05:29 -0500
commit235b0228dfcf53a457899e97c17c8ffe28857925 (patch)
treefe5be1db5bd40bdf7d8ba1cec37f1128dd661a99 /user/marco
parentb8707fadd090b59e731f693d9b8986472840fbb0 (diff)
downloadpackages-235b0228dfcf53a457899e97c17c8ffe28857925.tar.gz
packages-235b0228dfcf53a457899e97c17c8ffe28857925.tar.bz2
packages-235b0228dfcf53a457899e97c17c8ffe28857925.tar.xz
packages-235b0228dfcf53a457899e97c17c8ffe28857925.zip
user/marco: new package
Diffstat (limited to 'user/marco')
-rw-r--r--user/marco/APKBUILD40
-rw-r--r--user/marco/correctly-posix.patch12
2 files changed, 52 insertions, 0 deletions
diff --git a/user/marco/APKBUILD b/user/marco/APKBUILD
new file mode 100644
index 000000000..99289220b
--- /dev/null
+++ b/user/marco/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=marco
+pkgver=1.22.0
+pkgrel=0
+pkgdesc="Window manager for the MATE desktop environment"
+url="https://mate-desktop.org"
+arch="all"
+license="GPL-2.0+ AND MIT-advertising AND MIT-CMU"
+depends=""
+makedepends="gtk+3.0-dev intltool itstool libcanberra-dev libice-dev libsm-dev
+ libxml2-utils zenity"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/marco-$pkgver.tar.xz
+ correctly-posix.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0935ca1532fde882e21ebbc67b41afe80e15e8519b413b9b8bde351196be347a8dcac2e092da818ec0bc700216e38211f192a891eafec8ac7d9bf63d3a42328d marco-1.22.0.tar.xz
+b377b2a7d2af094a8b4bd6d1827c85f9675656cd8bdc6892b334c8479d188459ec8585fed3c746fdaef5820f768ce93605586693a3308f0db2d6f58e08f4df49 correctly-posix.patch"
diff --git a/user/marco/correctly-posix.patch b/user/marco/correctly-posix.patch
new file mode 100644
index 000000000..e2ad5fa18
--- /dev/null
+++ b/user/marco/correctly-posix.patch
@@ -0,0 +1,12 @@
+diff -Nurd marco-1.22.0/src/ui/theme.c marco-1.22.0.new/src/ui/theme.c
+--- marco-1.22.0/src/ui/theme.c 2019-02-08 08:51:33.000000000 -0600
++++ marco-1.22.0.new/src/ui/theme.c 2019-03-23 06:00:16.139892136 -0500
+@@ -60,7 +60,7 @@
+ #include <gtk/gtk.h>
+ #include <string.h>
+ #include <stdlib.h>
+-#define __USE_XOPEN
++#define _XOPEN_SOURCE
+ #include <math.h>
+
+ #define GDK_COLOR_RGBA(color) \