summaryrefslogtreecommitdiff
path: root/user/mimetic
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-07-31 15:02:28 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-07-31 15:02:28 -0500
commitd834ebd9b0f56f9f1765f1995c7a9a11d5fda3b4 (patch)
tree8069bf966c61aa5d3ccda54e75540aff23ec03e0 /user/mimetic
parent9b7fbf65ef40bd8a51bb247e3ba447d6bb211969 (diff)
downloadpackages-d834ebd9b0f56f9f1765f1995c7a9a11d5fda3b4.tar.gz
packages-d834ebd9b0f56f9f1765f1995c7a9a11d5fda3b4.tar.bz2
packages-d834ebd9b0f56f9f1765f1995c7a9a11d5fda3b4.tar.xz
packages-d834ebd9b0f56f9f1765f1995c7a9a11d5fda3b4.zip
user/mimetic: new package
Diffstat (limited to 'user/mimetic')
-rw-r--r--user/mimetic/APKBUILD52
-rw-r--r--user/mimetic/fix-compile.patch36
2 files changed, 88 insertions, 0 deletions
diff --git a/user/mimetic/APKBUILD b/user/mimetic/APKBUILD
new file mode 100644
index 000000000..6c3a4c542
--- /dev/null
+++ b/user/mimetic/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=mimetic
+pkgver=0.9.8
+pkgrel=0
+pkgdesc="C++ library for processing MIME"
+url="http://www.codesink.org/mimetic_mime_library.html"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://www.codesink.org/download/mimetic-$pkgver.tar.gz
+ fix-compile.patch
+ "
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+doc() {
+ depends="doxygen"
+ default_doc
+}
+
+sha512sums="4157eecb3e26af314d475c91192a357d6da35271a07a07b037d5037e9af84952ce2636874e86df0e94e8887dcfdb8f594a1ba04e6448181e436b0e2675f48f58 mimetic-0.9.8.tar.gz
+26badbaea0e9392080ece1cfda41d16a4fa87850e92edb4120e0a080fcebeeebaf28adb0fc73ba56ecacfc670bc315b2255c9c101471beb09068b1b4c4c8c473 fix-compile.patch"
diff --git a/user/mimetic/fix-compile.patch b/user/mimetic/fix-compile.patch
new file mode 100644
index 000000000..3bb93fa9a
--- /dev/null
+++ b/user/mimetic/fix-compile.patch
@@ -0,0 +1,36 @@
+diff -Nurd mimetic-0.9.8/test/cutee.cxx mimetic-0.9.8.new/test/cutee.cxx
+--- mimetic-0.9.8/test/cutee.cxx 2014-06-17 03:12:00.000000000 -0500
++++ mimetic-0.9.8.new/test/cutee.cxx 2018-07-26 22:40:21.556153371 -0500
+@@ -225,7 +225,7 @@
+ _( " run_" << *beg << "();" );
+ _( " tearDown();" );
+ _( " }" );
+- _( " uint count() { return " << m_fnList.size() << "; }" );
++ _( " unsigned int count() { return " << m_fnList.size() << "; }" );
+ _( "};" );
+ _("static struct "<<cn<<"_add_to_list: public cutee::TestList");
+ _( "{" );
+diff -Nurd mimetic-0.9.8/mimetic/codec/other_codecs.h mimetic-0.9.8.new/mimetic/codec/other_codecs.h
+--- mimetic-0.9.8/mimetic/codec/other_codecs.h 2014-06-17 03:12:00.000000000 -0500
++++ mimetic-0.9.8.new/mimetic/codec/other_codecs.h 2018-07-26 23:46:34.806277724 -0500
+@@ -109,7 +109,7 @@
+ : m_max(0), m_written(0)
+ {
+ }
+- MaxLineLen(uint m)
++ MaxLineLen(unsigned int m)
+ : m_max(m), m_written(0)
+ {
+ }
+diff -Nurd mimetic-0.9.8/mimetic/contenttype.cxx mimetic-0.9.8.new/mimetic/contenttype.cxx
+--- mimetic-0.9.8/mimetic/contenttype.cxx 2018-07-26 23:48:47.326281871 -0500
++++ mimetic-0.9.8.new/mimetic/contenttype.cxx 2018-07-26 23:49:58.686284105 -0500
+@@ -35,7 +35,7 @@
+ stringstream ss;
+ srand(time(0));
+ short tbSize = sizeof(tb)-1;
+- for(uint i=0; i < 48; ++i)
++ for(unsigned int i=0; i < 48; ++i)
+ {
+ unsigned int r = rand();
+ ss << tb[r % tbSize];