summaryrefslogtreecommitdiff
path: root/user/minivmac/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/minivmac/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/minivmac/APKBUILD')
-rw-r--r--user/minivmac/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/user/minivmac/APKBUILD b/user/minivmac/APKBUILD
index 71a16a1b2..08a38f1fb 100644
--- a/user/minivmac/APKBUILD
+++ b/user/minivmac/APKBUILD
@@ -10,15 +10,12 @@ options="!check" # minivmac does not ship a test suite
license="GPL-2.0-only"
depends=""
makedepends="libx11-dev libxcb-dev libxau-dev libbsd-dev libxdmcp-dev"
-source="http://oddball.tech/code/emu_pkg/$pkgname-$pkgver.tar.xz"
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz"
build() {
- cd "$builddir"
CARCH=$CARCH ./configure
- cd "$builddir"/mnvmplus
- make -j1
- cd "$builddir"/mnvmII
- make -j1
+ make -C mnvmplus -j1
+ make -C mnvmII -j1
}
package() {
@@ -26,4 +23,4 @@ package() {
install -m755 "$builddir"/mnvmII/minivmac "$pkgdir"/usr/bin/minivmacII
}
-sha512sums="ff28266641dd37df74c84c16c8bf32282729d55ae6512d4a98abf92ba40692f9fc107b501f072755ba0f8a0322d4f755915d9be74a407ce89af94bfd24d11043 minivmac-3.5.8.tar.xz"
+sha512sums="ff28266641dd37df74c84c16c8bf32282729d55ae6512d4a98abf92ba40692f9fc107b501f072755ba0f8a0322d4f755915d9be74a407ce89af94bfd24d11043 minivmac-3.5.8.tar.xz"