summaryrefslogtreecommitdiff
path: root/user/mlt
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-04-07 11:48:17 -0500
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-04-07 19:41:41 -0500
commit44e83eab207dd9294b58f37e9f5bdbab9fcd487b (patch)
tree01f6bfb78f343d89bd5cceea39f2618a413fd8a3 /user/mlt
parent1c07b0c9131d83bef427d329113ed773c7722714 (diff)
downloadpackages-44e83eab207dd9294b58f37e9f5bdbab9fcd487b.tar.gz
packages-44e83eab207dd9294b58f37e9f5bdbab9fcd487b.tar.bz2
packages-44e83eab207dd9294b58f37e9f5bdbab9fcd487b.tar.xz
packages-44e83eab207dd9294b58f37e9f5bdbab9fcd487b.zip
user/mlt: upgrade to 6.14.0
Diffstat (limited to 'user/mlt')
-rw-r--r--user/mlt/APKBUILD8
-rw-r--r--user/mlt/mlt-6.14.0-locale-header.patch12
-rw-r--r--user/mlt/mlt-6.8.0-locale-header.patch18
3 files changed, 16 insertions, 22 deletions
diff --git a/user/mlt/APKBUILD b/user/mlt/APKBUILD
index eedfc1e65..c42db62ba 100644
--- a/user/mlt/APKBUILD
+++ b/user/mlt/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=mlt
-pkgver=6.12.0
+pkgver=6.14.0
pkgrel=0
pkgdesc="MLT multimedia framework"
url="https://www.mltframework.org/"
@@ -13,7 +13,7 @@ makedepends="bsd-compat-headers ffmpeg-dev fftw-dev frei0r-plugins-dev
qt5-qtbase-dev qt5-qtsvg-dev sdl_image-dev sox-dev"
subpackages="$pkgname-dev"
source="https://github.com/mltframework/mlt/releases/download/v$pkgver/mlt-$pkgver.tar.gz
- mlt-6.8.0-locale-header.patch
+ mlt-6.14.0-locale-header.patch
"
build() {
@@ -45,5 +45,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="ed2cc0eeda45558ae6f1ec8780dfd413641953dc12dc32dccf655649f68f8e6088d39fefb7bef7bae042a41096976004446019d82ea162785bc487009cb97680 mlt-6.12.0.tar.gz
-c7c9fe70475ccf78c719c1ca6e1a7f2189e08abe04d556fe558dd787799bd7808d61326cfb2818eefe4a6868eed300b0c0d1480aa3df302b65b79a9a9aacc1b1 mlt-6.8.0-locale-header.patch"
+sha512sums="86b26b0c421cc881f6bebbde2c0ae9d834f190d8f878fb279ab29a1d7ac5416077b7dd91420bf63a7821fade9ca9c044a92440e02673c7b330b8ff36982a9fb9 mlt-6.14.0.tar.gz
+d00f01d50d5c78b1da5b43dc2b0bbfc49d5e383b602169ae9554734d29f6d43b9da8f97546141933c06ff0367bb4c9f0d2161bbcb6f016265bb0aa1dcbfcb3b1 mlt-6.14.0-locale-header.patch"
diff --git a/user/mlt/mlt-6.14.0-locale-header.patch b/user/mlt/mlt-6.14.0-locale-header.patch
new file mode 100644
index 000000000..28d659460
--- /dev/null
+++ b/user/mlt/mlt-6.14.0-locale-header.patch
@@ -0,0 +1,12 @@
+diff -Nurd mlt-6.14.0/src/framework/mlt_property.h mlt-6.14.0.new/src/framework/mlt_property.h
+--- mlt-6.14.0/src/framework/mlt_property.h 2019-03-30 15:59:21.000000000 -0500
++++ mlt-6.14.0.new/src/framework/mlt_property.h 2019-04-07 11:44:33.645881649 -0500
+@@ -30,7 +30,7 @@
+ #include <sys/param.h>
+ #endif
+
+-#if (defined(__GLIBC__) && !defined(__APPLE__)) || defined(HAVE_LOCALE_H)
++#if (defined(__linux__) && !defined(__APPLE__)) || defined(HAVE_LOCALE_H)
+ # include <locale.h>
+ #elif defined(__APPLE__) || (defined(__FreeBSD_version) && __FreeBSD_version >= 900506)
+ # include <xlocale.h>
diff --git a/user/mlt/mlt-6.8.0-locale-header.patch b/user/mlt/mlt-6.8.0-locale-header.patch
deleted file mode 100644
index 5b45b600a..000000000
--- a/user/mlt/mlt-6.8.0-locale-header.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Extremely incorrect logic here; fix it so that locale_t is defined properly.
-
---- mlt-6.8.0/src/framework/mlt_property.h.old 2018-05-10 20:16:56.000000000 -0500
-+++ mlt-6.8.0/src/framework/mlt_property.h 2018-06-07 05:22:57.345580154 -0500
-@@ -30,10 +30,10 @@
- #include <sys/param.h>
- #endif
-
--#if (defined(__GLIBC__) && !defined(__APPLE__)) || HAVE_LOCALE_H
--# include <locale.h>
--#elif defined(__APPLE__) || (__FreeBSD_version >= 900506)
-+#if defined(__APPLE__) || (__FreeBSD_version >= 900506)
- # include <xlocale.h>
-+#elif defined(__linux__) || HAVE_LOCALE_H
-+# include <locale.h>
- #else
- typedef char* locale_t;
- #endif