summaryrefslogtreecommitdiff
path: root/user/ncftp
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-11 01:54:54 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-11 01:54:54 +0000
commit21c4b84eb30afc752dd0ba5965c61dfc3bebac3d (patch)
tree1ca6f553222cbe4809067ffa24d6efafdae7b8df /user/ncftp
parent5efd7da9a9a79f82b4621cfd34fb8200c51f485a (diff)
downloadpackages-21c4b84eb30afc752dd0ba5965c61dfc3bebac3d.tar.gz
packages-21c4b84eb30afc752dd0ba5965c61dfc3bebac3d.tar.bz2
packages-21c4b84eb30afc752dd0ba5965c61dfc3bebac3d.tar.xz
packages-21c4b84eb30afc752dd0ba5965c61dfc3bebac3d.zip
user/*: Modernise / fix syntax / metadata / deps
Diffstat (limited to 'user/ncftp')
-rw-r--r--user/ncftp/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/user/ncftp/APKBUILD b/user/ncftp/APKBUILD
index 1a9b5fce4..dd1a31d21 100644
--- a/user/ncftp/APKBUILD
+++ b/user/ncftp/APKBUILD
@@ -8,13 +8,12 @@ url="http://www.ncftp.com/"
arch="all"
options="!check" # No test suite.
license="ClArtistic"
+depends=""
makedepends="ncurses-dev"
-source="ftp://ftp.ncftp.com/ncftp/$pkgname-$pkgver-src.tar.gz"
subpackages="$pkgname-doc $pkgname-bookmarks"
+source="ftp://ftp.ncftp.com/ncftp/$pkgname-$pkgver-src.tar.gz"
-build () {
- cd "$builddir"
-
+build() {
LIBS="-ltinfo" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -22,22 +21,18 @@ build () {
--sysconfdir=/etc \
--mandir=/usr/share/man
- cd "$builddir"/libncftp
- make shared
- cd "$builddir"
+ make -C libncftp shared
make
}
package() {
- cd "$builddir"/libncftp
- make PREFIX="${pkgdir}"/usr soinstall
- cd "$builddir"
+ make PREFIX="${pkgdir}"/usr -C libncftp soinstall
make DESTDIR="$pkgdir" install
install -D doc/LICENSE.txt \
"$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}
-bookmarks () {
+bookmarks() {
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/ncftpbookmarks \
"$subpkgdir"/usr/bin/