summaryrefslogtreecommitdiff
path: root/user/nextcloud-client/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-04-22 02:16:39 -0400
committerMax Rees <maxcrees@me.com>2019-04-22 02:16:39 -0400
commitbcc457430e844a29909b105a03a040b0bb994b10 (patch)
tree37e9a6202b52a77f8e6910fd528660a77a8abfdb /user/nextcloud-client/APKBUILD
parentcd19523e74f295530c3b71cc63875be405ecd440 (diff)
downloadpackages-bcc457430e844a29909b105a03a040b0bb994b10.tar.gz
packages-bcc457430e844a29909b105a03a040b0bb994b10.tar.bz2
packages-bcc457430e844a29909b105a03a040b0bb994b10.tar.xz
packages-bcc457430e844a29909b105a03a040b0bb994b10.zip
user/nextcloud-client: bump to 2.5.2
Diffstat (limited to 'user/nextcloud-client/APKBUILD')
-rw-r--r--user/nextcloud-client/APKBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/user/nextcloud-client/APKBUILD b/user/nextcloud-client/APKBUILD
index 549383413..ffd242b29 100644
--- a/user/nextcloud-client/APKBUILD
+++ b/user/nextcloud-client/APKBUILD
@@ -1,25 +1,22 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=nextcloud-client
-pkgver=2.5.0_beta2
-_ver="${pkgver%_beta2}-beta2"
+pkgver=2.5.2
pkgrel=0
pkgdesc="Nextcloud desktop client"
url="https://github.com/nextcloud/desktop"
arch="all"
-options="!checkroot"
license="GPL-2.0+ AND LGPL-2.1+ AND Public-Domain AND MIT AND (Custom:Digia-Qt OR LGPL-2.1-only WITH Qt-LGPL-exception-1.1) AND (Custom:Digia-Qt OR LGPL-2.1-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only)"
depends=""
makedepends="cmake qt5-qttools-dev qtkeychain-dev zlib-dev
openssl-dev sqlite-dev qt5-qtsvg-dev"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/nextcloud/desktop/archive/v$_ver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/nextcloud/desktop/archive/v$pkgver.tar.gz
no-webengine.patch
openssl.patch"
-builddir="$srcdir/desktop-$_ver"
+builddir="$srcdir/desktop-$pkgver"
build() {
- cd "$builddir"
cmake \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -27,20 +24,21 @@ build() {
-DCMAKE_INSTALL_SYSCONFDIR="/etc/$pkgname" \
-DNO_SHIBBOLETH=1 \
-DWITH_CRASHREPORTER=bool:OFF \
- -DUNIT_TESTING=bool:ON
+ -DUNIT_TESTING=bool:ON \
+ -DNO_SHIBBOLETH=bool:ON
make
}
check() {
- cd "$builddir"
- make test
+ # ChunkingTestNg fails sporadically when run with the other tests based
+ # on a timeout, but runs fine on its own
+ make test || make test ARGS="--rerun-failed --output-on-failure"
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="ed5ec8c0fd79d3f7f843ef1aefb9b94088b85dacca442388bc9a42e1ddbf1ee90482595135ffaffc85e40d223406964c903949ca1c2161fa0f6a2d6770a77cea nextcloud-client-2.5.0_beta2.tar.gz
-6bd83fdee02eabe7ae29fb1a677f62d4a416ec553a0f8c66b7544cafb9201dd7d8b04dc6fb21f447f6c1ece13b06f5d3cba57ac71b211e166607ef15350b3e57 no-webengine.patch
+sha512sums="1000b420355d7a4104ca5b41e813d467dcb345b60c79c78ce532de9c58ea89cad10d5565a433409bd512f0f7771c18c7c27974b968c74f84ccfda1ed3510d3ae nextcloud-client-2.5.2.tar.gz
+17e6a8437d33a2bb1305e45405aee4e23f233e00c232669a1f8317355032d88329899d3f7b65d1069cf1612029b589a575b0f64018b9b23d239a73c5f4bed2ce no-webengine.patch
e323a1074f8ac96667a420f076fdfc988e2fd97cdacd05d83ac54b467b567f5adbf635e7c4fb0414af0012b4016cc4c13441cb35ed3976bc970e514e81b65fd4 openssl.patch"