summaryrefslogtreecommitdiff
path: root/user/nmap/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/nmap/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/nmap/APKBUILD')
-rw-r--r--user/nmap/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/user/nmap/APKBUILD b/user/nmap/APKBUILD
index 3b256aaa3..304c94cae 100644
--- a/user/nmap/APKBUILD
+++ b/user/nmap/APKBUILD
@@ -7,7 +7,8 @@ url="https://nmap.org/"
arch="all"
license="GPL-2.0-only"
depends=""
-makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev libssh2-dev lua5.3-dev"
+makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev
+ libssh2-dev lua5.3-dev"
subpackages="
$pkgname-doc
$pkgname-scripts::noarch
@@ -33,7 +34,7 @@ build() {
export CFLAGS=-g3
export CPPFLAGS=-g3
export CXXFLAGS=-g3
- ./configure \
+ LDFLAGS="$LDFLAGS -L/usr/lib/lua5.3" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -47,7 +48,7 @@ build() {
--with-libpcre=yes \
--with-libz=yes \
--with-libssh2=yes \
- --with-liblua=/usr/lua5.3
+ --with-liblua=yes
make
}