summaryrefslogtreecommitdiff
path: root/user/nmap
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 10:08:19 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 10:08:19 +0000
commite70325e83d97d6cef9bd38f6c5e4e0a7af5dd6fc (patch)
tree4df05ec7d211d0ea00d087e5ef7e17f1eb56248f /user/nmap
parentcd33dc8f0ee48b00991e1b0f8833b8e65a8770d8 (diff)
downloadpackages-e70325e83d97d6cef9bd38f6c5e4e0a7af5dd6fc.tar.gz
packages-e70325e83d97d6cef9bd38f6c5e4e0a7af5dd6fc.tar.bz2
packages-e70325e83d97d6cef9bd38f6c5e4e0a7af5dd6fc.tar.xz
packages-e70325e83d97d6cef9bd38f6c5e4e0a7af5dd6fc.zip
user/*: Modernise / fix syntax / deps / code / tests
Diffstat (limited to 'user/nmap')
-rw-r--r--user/nmap/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/user/nmap/APKBUILD b/user/nmap/APKBUILD
index 3b256aaa3..304c94cae 100644
--- a/user/nmap/APKBUILD
+++ b/user/nmap/APKBUILD
@@ -7,7 +7,8 @@ url="https://nmap.org/"
arch="all"
license="GPL-2.0-only"
depends=""
-makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev libssh2-dev lua5.3-dev"
+makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev
+ libssh2-dev lua5.3-dev"
subpackages="
$pkgname-doc
$pkgname-scripts::noarch
@@ -33,7 +34,7 @@ build() {
export CFLAGS=-g3
export CPPFLAGS=-g3
export CXXFLAGS=-g3
- ./configure \
+ LDFLAGS="$LDFLAGS -L/usr/lib/lua5.3" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -47,7 +48,7 @@ build() {
--with-libpcre=yes \
--with-libz=yes \
--with-libssh2=yes \
- --with-liblua=/usr/lua5.3
+ --with-liblua=yes
make
}