summaryrefslogtreecommitdiff
path: root/user/ntp/APKBUILD
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-05-20 02:54:35 -0700
committerDan Theisen <djt@hxx.in>2018-05-20 02:54:35 -0700
commit4897f743b6555bf29a78120183f8250afc7e5d58 (patch)
tree7a4c76293889c341138c98cffd9e7114267ab365 /user/ntp/APKBUILD
parent9b7f4079a05641ff18208632e516c7a68df14dcd (diff)
downloadpackages-4897f743b6555bf29a78120183f8250afc7e5d58.tar.gz
packages-4897f743b6555bf29a78120183f8250afc7e5d58.tar.bz2
packages-4897f743b6555bf29a78120183f8250afc7e5d58.tar.xz
packages-4897f743b6555bf29a78120183f8250afc7e5d58.zip
ntp: new package
Diffstat (limited to 'user/ntp/APKBUILD')
-rw-r--r--user/ntp/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/user/ntp/APKBUILD b/user/ntp/APKBUILD
new file mode 100644
index 000000000..a7e38c830
--- /dev/null
+++ b/user/ntp/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=ntp
+pkgver=4.2.8p11
+pkgrel=0
+pkgdesc="an implementation of RFC-5905 (NTPv4)"
+url="http://www.ntp.org/"
+arch="all"
+license="BSD-2-Clause"
+depends=""
+makedepends="openssl-dev libedit-dev"
+subpackages="$pkgname-dbg $pkgname-doc"
+source="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/$pkgname-${pkgname%.*}/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --with-lineeditlibs=edit \
+ --enable-debugging \
+ --enable-ipv6 \
+ --with-crypto \
+ --enable-autokey
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="05ac60f15a6aac50aaf340d40e4e439a421fa6e3d897bf30a69b2cef0cc97f8a6956012bfc6ceba055f4c3485a24f7fb8ebbd055e1875f1c69cbfdc35e71f236 ntp-4.2.8p11.tar.gz"