summaryrefslogtreecommitdiff
path: root/user/numactl/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-07-06 19:19:37 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-07-06 19:19:37 +0000
commitcdd7c92be92eb782d733a446e753ca89917bc7d5 (patch)
tree0d84fc7fa2f73746e84a849572151605b348bd63 /user/numactl/APKBUILD
parent5846d0776b625f7edbbbe552f2761bf72babd370 (diff)
parentc50636433139f26543aad061d54c3708b2a4e22a (diff)
downloadpackages-cdd7c92be92eb782d733a446e753ca89917bc7d5.tar.gz
packages-cdd7c92be92eb782d733a446e753ca89917bc7d5.tar.bz2
packages-cdd7c92be92eb782d733a446e753ca89917bc7d5.tar.xz
packages-cdd7c92be92eb782d733a446e753ca89917bc7d5.zip
Merge branch 'popular-demand' into master
Popular Demand Packages -- MR #1 See merge request adelie/packages!269
Diffstat (limited to 'user/numactl/APKBUILD')
-rw-r--r--user/numactl/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/user/numactl/APKBUILD b/user/numactl/APKBUILD
new file mode 100644
index 000000000..a6122fcc5
--- /dev/null
+++ b/user/numactl/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=numactl
+pkgver=2.0.12
+pkgrel=0
+pkgdesc="Simple NUMA policy support"
+url="https://github.com/numactl/numactl"
+# ARM lacks the __NR_migrate_pages syscall
+arch="all !armhf !armv7"
+license="GPL-2.0+ AND LGPL-2.1"
+makedepends="autoconf automake libtool linux-headers"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/numactl/$pkgname/archive/v$pkgver.tar.gz
+ musl.patch"
+
+prepare() {
+ default_prepare
+ ./autogen.sh
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+check() {
+ make check VERBOSE=1 TESTS='test/distance test/nodemap test/tbitmap'
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+
+ # provided by linux man-pages
+ rm -r "$pkgdir"/usr/share/man/man2
+}
+
+tools() {
+ pkgdesc="NUMA policy control tools"
+
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+sha512sums="3814efd924d1c9152a30f6ae5b665afc20648226cd475d72b933c0ec4f30249af4e25110de17f144734b787ed765644dca09a657219806ab5c9c550abd45bf8e numactl-2.0.12.tar.gz
+c24affa5a8a8ea83d7f0ee384dc0629e17a5c4201357132f770f894ad4236772116d96d8389d54fb99095af40d1ccbffc3170b5fb9cc88cfca39179f50bee9c9 musl.patch"