summaryrefslogtreecommitdiff
path: root/user/ode
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 09:08:07 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 09:08:07 +0000
commite43c6ac7e6a5d054e6bbd47650f4b2531df91017 (patch)
tree15ef27c72b46256c95aca12b49ca10e3b117ee26 /user/ode
parenta659f1f6d9acf841ab364e2b031a56dc1b630698 (diff)
downloadpackages-e43c6ac7e6a5d054e6bbd47650f4b2531df91017.tar.gz
packages-e43c6ac7e6a5d054e6bbd47650f4b2531df91017.tar.bz2
packages-e43c6ac7e6a5d054e6bbd47650f4b2531df91017.tar.xz
packages-e43c6ac7e6a5d054e6bbd47650f4b2531df91017.zip
user/*: Modernise / fix syntax / deps / code
Diffstat (limited to 'user/ode')
-rw-r--r--user/ode/APKBUILD8
-rw-r--r--user/ode/stdint.patch44
2 files changed, 47 insertions, 5 deletions
diff --git a/user/ode/APKBUILD b/user/ode/APKBUILD
index 24c1fcc74..9e1f520d1 100644
--- a/user/ode/APKBUILD
+++ b/user/ode/APKBUILD
@@ -13,11 +13,10 @@ makedepends="autoconf automake libtool"
subpackages="$pkgname-dev"
source="https://bitbucket.org/odedevs/ode/downloads/ode-$pkgver.tar.gz
fix-test-link.patch
+ stdint.patch
"
build() {
- cd "$builddir"
-
./bootstrap
CXXFLAGS="$CXXFLAGS -fpermissive" ./configure \
--build=$CBUILD \
@@ -35,14 +34,13 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="302e6f689851acb9ba0db23e13ab59ae0acbbd8dbdfa7e277b57d870c0d3435274e64da16134fb4b7053f951489c138e485165d79664d11764a88b3437d703d3 ode-0.16.tar.gz
-8630d5d059fd0f623db6af4000666868358002a42ba84817117b1fb5e01c776bb23cbf1c8c43181d7bf40a0d71b640f9d2f9785461d8a77877dcbdadd775792e fix-test-link.patch"
+8630d5d059fd0f623db6af4000666868358002a42ba84817117b1fb5e01c776bb23cbf1c8c43181d7bf40a0d71b640f9d2f9785461d8a77877dcbdadd775792e fix-test-link.patch
+0d618cec0afdab86279687275bf476594897d1dfd7b5619fe6bc05343f22f6292c9598a73ff6f2967d5f39e071abcf282fc673c0ffe33f7efd9bbe56ca674dae stdint.patch"
diff --git a/user/ode/stdint.patch b/user/ode/stdint.patch
new file mode 100644
index 000000000..f3674335e
--- /dev/null
+++ b/user/ode/stdint.patch
@@ -0,0 +1,44 @@
+--- ode-0.16/include/ode/odeconfig.h.old 2018-12-09 20:04:03.000000000 +0000
++++ ode-0.16/include/ode/odeconfig.h 2020-01-12 08:36:16.664428956 +0000
+@@ -32,6 +32,7 @@
+ #include <math.h>
+ #include <string.h>
+ #include <float.h>
++#include <stdint.h>
+
+
+ #include <ode/precision.h>
+@@ -128,20 +129,20 @@
+ typedef __int64 dint64;
+ typedef unsigned __int64 duint64;
+ #else
+- typedef long long dint64;
+- typedef unsigned long long duint64;
++ typedef int64_t dint64;
++ typedef uint64_t duint64;
+ #endif
+- typedef int dint32;
+- typedef unsigned int duint32;
+- typedef short dint16;
+- typedef unsigned short duint16;
+- typedef signed char dint8;
+- typedef unsigned char duint8;
+-
+- typedef dint32 dintptr;
+- typedef duint32 duintptr;
+- typedef dint32 ddiffint;
+- typedef duint32 dsizeint;
++ typedef int32_t dint32;
++ typedef uint32_t duint32;
++ typedef int16_t dint16;
++ typedef uint16_t duint16;
++ typedef int8_t dint8;
++ typedef uint8_t duint8;
++
++ typedef intptr_t dintptr;
++ typedef uintptr_t duintptr;
++ typedef ptrdiff_t ddiffint;
++ typedef size_t dsizeint;
+
+ #endif
+