summaryrefslogtreecommitdiff
path: root/user/okular
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-19 07:33:49 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-19 07:33:49 +0000
commite4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e (patch)
tree765c43e23668dd79b2dab94029fb96813c7f824e /user/okular
parent6162950549630e75dd1f2d3037cabd23559b2822 (diff)
downloadpackages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.tar.gz
packages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.tar.bz2
packages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.tar.xz
packages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.zip
user/*: KDE Applications 19.04.0
Diffstat (limited to 'user/okular')
-rw-r--r--user/okular/0001-Ensure-compatibility-with-Qt.patch36
-rw-r--r--user/okular/APKBUILD9
2 files changed, 42 insertions, 3 deletions
diff --git a/user/okular/0001-Ensure-compatibility-with-Qt.patch b/user/okular/0001-Ensure-compatibility-with-Qt.patch
new file mode 100644
index 000000000..dfd2daa75
--- /dev/null
+++ b/user/okular/0001-Ensure-compatibility-with-Qt.patch
@@ -0,0 +1,36 @@
+From 00f76c2df98c44722b05f7c350cf6b3241c2128f Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Thu, 18 Apr 2019 18:17:32 -0500
+Subject: [PATCH] Ensure compatibility with Qt <5.10
+
+Qt::AA_CompressTabletEvents was added in Qt 5.10. Use preprocessor check
+to avoid build failures on 5.9 LTS or 5.8 (the minimum version).
+---
+ shell/main.cpp | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/shell/main.cpp b/shell/main.cpp
+index 17b58c610..dbdebf1a4 100644
+--- a/shell/main.cpp
++++ b/shell/main.cpp
+@@ -19,6 +19,7 @@
+ #include <QTextStream>
+ #include <kwindowsystem.h>
+ #include <QApplication>
++#include <QtGlobal>
+ #include <KAboutData>
+ #include <KCrash>
+ #include <KMessageBox>
+@@ -31,7 +32,9 @@
+ int main(int argc, char** argv)
+ {
+ QGuiApplication::setAttribute(Qt::AA_UseHighDpiPixmaps);
++#if QT_VERSION >= 0x051000
+ QCoreApplication::setAttribute(Qt::AA_CompressTabletEvents);
++#endif
+
+ QApplication app(argc, argv);
+ KLocalizedString::setApplicationDomain("okular");
+--
+2.21.0
+
diff --git a/user/okular/APKBUILD b/user/okular/APKBUILD
index ed7175568..7a8fa0fa6 100644
--- a/user/okular/APKBUILD
+++ b/user/okular/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=okular
-pkgver=18.12.3
+pkgver=19.04.0
pkgrel=0
pkgdesc="Universal document reader developed by KDE"
url="https://okular.kde.org/"
@@ -16,7 +16,9 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kconfig-dev
libjpeg-turbo-dev kpty-dev kirigami2-dev djvulibre-dev libkexiv2-dev
libspectre-dev ebook-tools-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/applications/$pkgver/src/okular-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/okular-$pkgver.tar.xz
+ 0001-Ensure-compatibility-with-Qt.patch
+ "
build() {
cd "$builddir"
@@ -45,4 +47,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="cbbf20657b6d0c5837d1400fb5be17410672e2489372f62f247b380bd38c0f3ef412d179b683a92d592a906855a648e997c6db5898e29365dcefdf7a8192bf11 okular-18.12.3.tar.xz"
+sha512sums="8a28f0cafb9b4ae8f5b3720958ccf511b9c40bbbe9b725fac11e103b1ebbb4a8a7cf84917cbe355bae7bd279584902e14907eafed2c5145b3c83d80d0a5ae25f okular-19.04.0.tar.xz
+cdaae2b04abaa4663e6a9f1e95dc3659c756ad1f159dc85bad52b6d55b37aef9aa7e52e773687f6295b248f6df0518e59d9da45d5819354f9eea407037a6959c 0001-Ensure-compatibility-with-Qt.patch"