summaryrefslogtreecommitdiff
path: root/user/openldap
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-25 06:16:32 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-25 06:16:32 -0600
commit754b3fc000a30529e63362a7b4921bf697468232 (patch)
tree0f72607e29a7e741e06127df2507482e5a33e32d /user/openldap
parent5fa1a959ce020d9e72d9232fe9205b274cac086d (diff)
downloadpackages-754b3fc000a30529e63362a7b4921bf697468232.tar.gz
packages-754b3fc000a30529e63362a7b4921bf697468232.tar.bz2
packages-754b3fc000a30529e63362a7b4921bf697468232.tar.xz
packages-754b3fc000a30529e63362a7b4921bf697468232.zip
user/*: Fix metadata
Diffstat (limited to 'user/openldap')
-rw-r--r--user/openldap/APKBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/user/openldap/APKBUILD b/user/openldap/APKBUILD
index 3f84e64c7..ffff4c1a7 100644
--- a/user/openldap/APKBUILD
+++ b/user/openldap/APKBUILD
@@ -1,5 +1,4 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
#
# secfixes:
# 2.4.48-r0:
@@ -15,20 +14,20 @@ pkgname=openldap
pkgver=2.4.48
pkgrel=0
pkgdesc="LDAP Server"
-url="http://www.openldap.org/"
+url="https://www.openldap.org/"
arch="all"
options="!check" # Test suite takes > 2 hours to complete on each builder.
-license="custom"
+license="OLDAP-2.8"
depends=""
-pkgusers="ldap"
-pkggroups="ldap"
depends_dev="openssl-dev cyrus-sasl-dev util-linux-dev"
-makedepends="$depends_dev db-dev groff unixodbc-dev libtool
+makedepends="$depends_dev db-dev groff icu-dev unixodbc-dev
autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc libldap $pkgname-openrc
$pkgname-clients $pkgname-passwd-pbkdf2:passwd_pbkdf2
$pkgname-backend-all:_backend_all:noarch
$pkgname-overlay-all:_overlay_all:noarch"
+pkgusers="ldap"
+pkggroups="ldap"
install="$pkgname.pre-install $pkgname.post-install $pkgname.post-upgrade"
source="ftp://ftp.$pkgname.org/pub/OpenLDAP/$pkgname-release/$pkgname-$pkgver.tgz
openldap-2.4-ppolicy.patch
@@ -60,7 +59,7 @@ do
done
prepare() {
- cd "$builddir"
+ default_prepare
update_config_sub
sed -i '/^STRIP/s,-s,,g' build/top.mk
@@ -68,8 +67,6 @@ prepare() {
}
build () {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -106,13 +103,10 @@ build () {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
# Install passwd pbkdf2.
@@ -124,8 +118,8 @@ package() {
rmdir var/lib/openldap/run
# Fix tools symlinks to slapd.
- local path; for path in $(find usr/sbin/ -type l); do
- ln -sf slapd $path
+ for _path in $(find usr/sbin/ -type l); do
+ ln -sf slapd $_path
done
# Move executable from lib to sbin.
@@ -149,7 +143,6 @@ package() {
libldap() {
pkgdesc="OpenLDAP libraries"
depends=""
- install=""
_submv "usr/lib/*.so*" etc/openldap/ldap.conf
}
@@ -199,7 +192,7 @@ _overlay() {
}
_submv() {
- local path; for path in "$@"; do
+ for path in "$@"; do
mkdir -p "$subpkgdir"/${path%/*}
mv "$pkgdir"/$path "$subpkgdir"/${path%/*}/
done