summaryrefslogtreecommitdiff
path: root/user/openmsx
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-12 18:29:07 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-12 18:29:07 +0000
commitb99c23f4b87c1ca0e3fc6f324a0cbf6804cf70bc (patch)
treeaf719aea434e3b3d373615270cfbc95e957d6272 /user/openmsx
parentdb66031379c690f03ea3ada111a7434af8625725 (diff)
downloadpackages-b99c23f4b87c1ca0e3fc6f324a0cbf6804cf70bc.tar.gz
packages-b99c23f4b87c1ca0e3fc6f324a0cbf6804cf70bc.tar.bz2
packages-b99c23f4b87c1ca0e3fc6f324a0cbf6804cf70bc.tar.xz
packages-b99c23f4b87c1ca0e3fc6f324a0cbf6804cf70bc.zip
user/openmsx: port new package to Python 3
Diffstat (limited to 'user/openmsx')
-rw-r--r--user/openmsx/APKBUILD34
-rw-r--r--user/openmsx/python3.patch265
2 files changed, 299 insertions, 0 deletions
diff --git a/user/openmsx/APKBUILD b/user/openmsx/APKBUILD
new file mode 100644
index 000000000..5e29f657e
--- /dev/null
+++ b/user/openmsx/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=openmsx
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="Music files for OpenTTD"
+url="https://www.openttd.org/en/"
+arch="noarch"
+options="!check" # No way to test MIDIs
+license="GPL-2.0-only"
+depends=""
+makedepends="python3"
+subpackages=""
+source="https://binaries.openttd.org/extra/openmsx/0.3.1/openmsx-$pkgver-source.tar.gz
+ python3.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver-source"
+
+build() {
+ cd "$builddir"
+ make _V="" bundle
+}
+
+package() {
+ cd "$builddir"/$pkgname-$pkgver
+ local _file
+ for _file in *.mid openmsx.obm; do
+ install -D -m644 -g games $_file \
+ "$pkgdir"/usr/share/games/openttd/gm/$_file
+ done
+}
+
+sha512sums="e455f99f32d1daa77157def4f109dd1456169ae2b527290035b6a52f591c13fb7464fd221e00eb46bf03f51e8d0101de08a9e47cebe2430ad05a840ab235973e openmsx-0.3.1-source.tar.gz
+b6690158831cb3da9e0e65a523529ee0bb694a4a8b23c89f615b2481601a71fd84caecf29430054e69afa3ffcb53cf8dd5826358d7ef89429c661dd4d47bbb74 python3.patch"
diff --git a/user/openmsx/python3.patch b/user/openmsx/python3.patch
new file mode 100644
index 000000000..191aacfd6
--- /dev/null
+++ b/user/openmsx/python3.patch
@@ -0,0 +1,265 @@
+--- openmsx-0.3.1-source/scripts/authorlist.py.old 2010-08-09 22:34:42.000000000 +0000
++++ openmsx-0.3.1-source/scripts/authorlist.py 2019-01-12 18:12:26.010000000 +0000
+@@ -10,7 +10,6 @@
+ # <http://www.gnu.org/licenses/>.
+ #
+
+-import string
+ import sys
+
+ while 1:
+@@ -18,10 +17,10 @@
+ if data != '':
+ # do some processing of the contents of
+ # the data variable
+- separate = string.split(data,";")
+- print '%-30s %s' % (separate[1]+":", separate[2])
++ separate = data.split(";")
++ print('%-30s %s' % (separate[1]+":", separate[2]))
+ # end of data processing command group
+- # sys.stdout.write(res)
++ # sys.stdout.write(res)
+ else:
+ sys.stdout.flush()
+ break
+--- openmsx-0.3.1-source/scripts/md5list.py.old 2010-08-09 22:34:42.000000000 +0000
++++ openmsx-0.3.1-source/scripts/md5list.py 2019-01-12 18:16:21.260000000 +0000
+@@ -10,7 +10,6 @@
+ # <http://www.gnu.org/licenses/>.
+ #
+
+-import string
+ import sys
+ import subprocess
+ import os
+@@ -18,25 +17,25 @@
+ while 1:
+ data = sys.stdin.readline()
+ if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- systemtype = (os.uname())[0]
+- if systemtype == 'Linux':
+- md5call = ["md5sum"]
+- elif systemtype == 'Darwin':
+- md5call = ["md5", "-r"]
+- else:
+- md5call = ["md5sum"]
+- md5call = md5call + ["src/"+string.strip(separate[1])]
+- md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
+- md5sum = string.split(md5sum)
+- res = "%-32s = %s\n" % (separate[1], md5sum[0])
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = data.find('#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = data.split(";")
++ if len(separate) != 4:
++ continue
++ systemtype = (os.uname())[0]
++ if systemtype == 'Linux':
++ md5call = ["md5sum"]
++ elif systemtype == 'Darwin':
++ md5call = ["md5", "-r"]
++ else:
++ md5call = ["md5sum"]
++ md5call = md5call + ["src/"+separate[1].strip()]
++ md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
++ md5sum = md5sum.split()
++ res = "%-32s = %s\n" % (separate[1], md5sum[0].decode('utf-8'))
+ sys.stdout.write(res)
+ else:
+ sys.stdout.flush()
+--- openmsx-0.3.1-source/scripts/midifiles.py.old 2010-08-09 22:34:42.000000000 +0000
++++ openmsx-0.3.1-source/scripts/midifiles.py 2019-01-12 18:09:21.660000000 +0000
+@@ -10,23 +10,22 @@
+ # <http://www.gnu.org/licenses/>.
+ #
+
+-import string
+ import sys
+
+ res = ""
+ while 1:
+ data = sys.stdin.readline()
+ if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- res = res + " src/" + string.strip(separate[1])
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = data.find('#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = data.split(";")
++ if len(separate) != 4:
++ continue
++ res = res + " src/" + separate[1].strip()
+ else:
+- sys.stdout.write(res)
++ sys.stdout.write(res)
+ sys.stdout.flush()
+ break
+--- openmsx-0.3.1-source/scripts/namelist.py.old 2010-08-09 22:34:42.000000000 +0000
++++ openmsx-0.3.1-source/scripts/namelist.py 2019-01-12 18:24:41.820000000 +0000
+@@ -10,27 +10,26 @@
+ # <http://www.gnu.org/licenses/>.
+ #
+
+-import string
+ import sys
+
+ while 1:
+ data = sys.stdin.readline()
+ if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- res = "%-32s = %s\n" % (separate[1], string.strip(separate[3]))
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = data.find('#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = data.split(";")
++ if len(separate) != 4:
++ continue
++ res = "%-32s = %s\n" % (separate[1], separate[3].strip())
+ sys.stdout.write(res)
+ else:
+ sys.stdout.flush()
+ break
+
+ def authorlist(mystr):
+- separate = string.split()
+- for str in separate:
+- print string.strip(str)
+\ No newline at end of file
++ separate = mystr.split()
++ for str in separate:
++ print(str.strip())
+--- openmsx-0.3.1-source/scripts/playlist.py.old 2010-08-09 22:34:42.000000000 +0000
++++ openmsx-0.3.1-source/scripts/playlist.py 2019-01-12 18:24:46.440000000 +0000
+@@ -10,31 +10,30 @@
+ # <http://www.gnu.org/licenses/>.
+ #
+
+-import string
+ import sys
+
+ while 1:
+ data = sys.stdin.readline()
+ if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- res = ""
+- # leave out all lines which don't have the proper number of elements
+- if len(separate) >= 1:
+- res = string.strip(separate[0]) + " = "
+- if len(separate) == 4:
+- res = res + separate[1]
+- res = res + "\n"
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = data.find('#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = data.split(";")
++ res = ""
++ # leave out all lines which don't have the proper number of elements
++ if len(separate) >= 1:
++ res = separate[0].strip() + " = "
++ if len(separate) == 4:
++ res = res + separate[1]
++ res = res + "\n"
+ sys.stdout.write(res)
+ else:
+ sys.stdout.flush()
+ break
+
+ def authorlist(mystr):
+- separate = string.split()
+- for str in separate:
+- print string.strip(str)
+\ No newline at end of file
++ separate = mystr.split()
++ for str in separate:
++ print(str.strip())
+--- openmsx-0.3.1-source/scripts/sanitize_list.py.old 2010-08-09 22:34:42.000000000 +0000
++++ openmsx-0.3.1-source/scripts/sanitize_list.py 2019-01-12 18:25:21.200000000 +0000
+@@ -10,34 +10,33 @@
+ # <http://www.gnu.org/licenses/>.
+ #
+
+-import string
+ import sys
+
+ while 1:
+ data = sys.stdin.readline()
+ if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- res = ""
+- for str in separate:
+- if res != '':
+- res = res + ";" + string.strip(str)
+- else:
+- res = string.strip(str)
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = data.find('#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = data.split(";")
++ if len(separate) != 4:
++ continue
++ res = ""
++ for str in separate:
++ if res != '':
++ res = res + ";" + str.strip()
++ else:
++ res = str.strip()
+ # end of data processing command group
+- res = res + "\n"
++ res = res + "\n"
+ sys.stdout.write(res)
+ else:
+ sys.stdout.flush()
+ break
+
+ def authorlist(mystr):
+- separate = string.split()
+- for str in separate:
+- print string.strip(str)
+\ No newline at end of file
++ separate = mystr.split()
++ for str in separate:
++ print(str.strip())