summaryrefslogtreecommitdiff
path: root/user/os-prober
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/os-prober
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/os-prober')
-rw-r--r--user/os-prober/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/user/os-prober/APKBUILD b/user/os-prober/APKBUILD
index 65ff5061b..016f92168 100644
--- a/user/os-prober/APKBUILD
+++ b/user/os-prober/APKBUILD
@@ -8,7 +8,7 @@ url="http://joeyh.name/code/os-prober/"
arch="all"
options="!check" # No test suite.
license="GPL-2.0+ AND GPL-1.0+"
-depends="/bin/sh"
+depends="/bin/sh grub-mount"
makedepends=""
subpackages=""
source="http://deb.debian.org/debian/pool/main/o/os-prober/os-prober_$pkgver.tar.xz"
@@ -32,19 +32,21 @@ package() {
linux-boot-probes linux-boot-probes/mounted; do
mkdir -p "$pkgdir/usr/lib/$probes"
for file in $probes/common/*; do
- install -Dm644 $file "$pkgdir/usr/lib/$probes"
+ install -Dm755 $file "$pkgdir/usr/lib/$probes"
done
if [ -e "$probes/${PROBE_ARCH}" ]; then
- install -Dm644 $probes/${PROBE_ARCH}/* \
- "$pkgdir/usr/lib/$probes"
+ mkdir -p "$pkgdir/usr/lib/$probes/${PROBE_ARCH}"
+ cp -a $probes/${PROBE_ARCH}/* \
+ "$pkgdir/usr/lib/$probes/${PROBE_ARCH}"
fi
done
mkdir -p "$pkgdir"/usr/lib/os-prober "$pkgdir"/usr/bin
mkdir -p "$pkgdir"/usr/share/os-prober
+ install -dm700 "$pkgdir"/var/lib/os-prober
install -Dm755 newns "$pkgdir"/usr/lib/os-prober/
install -Dm755 os-prober "$pkgdir"/usr/bin/
install -Dm755 linux-boot-prober "$pkgdir"/usr/bin/
- install -Dm644 common.sh "$pkgdir"/usr/share/os-prober/
+ install -Dm755 common.sh "$pkgdir"/usr/share/os-prober/
}
sha512sums="4d9c22ccc4d950644a06a17ec4424aca5ff82aeb20052dc389dd451b6b9a1799c5a9438644a29093153730af42066abbbbb78f593f2564314c9adbd43f60e39b os-prober_1.77.tar.xz"