summaryrefslogtreecommitdiff
path: root/user/perl-data-section
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-04-26 18:05:19 -0500
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-04-26 18:05:19 -0500
commit0ac1f672329855a4d094e9191961d646a5f375af (patch)
tree7c46905133f9473840fb76ee9cdac4a071695b41 /user/perl-data-section
parent2d5749c0cfde29ccf0d7e660bec5a1fda07d66de (diff)
downloadpackages-0ac1f672329855a4d094e9191961d646a5f375af.tar.gz
packages-0ac1f672329855a4d094e9191961d646a5f375af.tar.bz2
packages-0ac1f672329855a4d094e9191961d646a5f375af.tar.xz
packages-0ac1f672329855a4d094e9191961d646a5f375af.zip
user/perl-data-section: new package
Diffstat (limited to 'user/perl-data-section')
-rw-r--r--user/perl-data-section/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/perl-data-section/APKBUILD b/user/perl-data-section/APKBUILD
new file mode 100644
index 000000000..1e874f9ba
--- /dev/null
+++ b/user/perl-data-section/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-data-section
+pkgver=0.200007
+pkgrel=0
+pkgdesc="Perl module for reading inline data in chunks"
+url="https://metacpan.org/pod/Data::Section"
+arch="noarch"
+license="Artistic-1.0-Perl"
+depends="perl perl-mro-compat perl-sub-exporter perl-test-failwarnings"
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/Data-Section-$pkgver.tar.gz"
+builddir="$srcdir/Data-Section-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="0c23141ccc2041e8c1c222c95d6eab4b56e2d77a94c68507f67acbb62fa5132e9229e9680c9fff6ebbc6a47a42cf1943d6e5b50a5f0168c66193fb52aaa241f0 Data-Section-0.200007.tar.gz"