summaryrefslogtreecommitdiff
path: root/user/perl-extutils-parsexs
diff options
context:
space:
mode:
authorKiyoshi Aman <adelie@aerdan.vulpine.house>2020-02-14 12:25:12 -0500
committerKiyoshi Aman <adelie@aerdan.vulpine.house>2020-02-14 12:25:12 -0500
commit786dcd00e31618ab7600e15c8ba8e1d075def91a (patch)
treeae06f418aee5a9389cfa36946ac276cf96776761 /user/perl-extutils-parsexs
parenta434ec330036cce835fc97013f87afa99947239a (diff)
downloadpackages-786dcd00e31618ab7600e15c8ba8e1d075def91a.tar.gz
packages-786dcd00e31618ab7600e15c8ba8e1d075def91a.tar.bz2
packages-786dcd00e31618ab7600e15c8ba8e1d075def91a.tar.xz
packages-786dcd00e31618ab7600e15c8ba8e1d075def91a.zip
user/perl-extutils-parsexs: new package
Diffstat (limited to 'user/perl-extutils-parsexs')
-rw-r--r--user/perl-extutils-parsexs/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/perl-extutils-parsexs/APKBUILD b/user/perl-extutils-parsexs/APKBUILD
new file mode 100644
index 000000000..feb576d92
--- /dev/null
+++ b/user/perl-extutils-parsexs/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-extutils-parsexs
+_pkgreal=ExtUtils-ParseXS
+_author=SMUELLER
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
+pkgver=3.35
+pkgrel=0
+pkgdesc="Perl module for converting XS code into C"
+url="https://metacpan.org/pod/ExtUtils::ParseXS"
+arch="all"
+license="Artistic-2.0 OR GPL-2.0-only"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/ExtUtils-ParseXS-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="90862ecb97f19066a4564be1788bd061c5835abb440fbea2cad43c903e912a7864453ef61c2c384566a4fe6536783f480938c4460b63879734a2d74372a956b8 ExtUtils-ParseXS-3.35.tar.gz"