summaryrefslogtreecommitdiff
path: root/user/perl-ipc-run/APKBUILD
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-09-27 21:27:53 -0700
committerDan Theisen <djt@hxx.in>2018-09-27 21:27:53 -0700
commita9317a57f10e562a57e3a964868688aef8a70129 (patch)
tree2e5cbbb452fca25fc19d03674b7091147a11f063 /user/perl-ipc-run/APKBUILD
parentdc251ca63b8863a75b90fe2f2924b4aad463a959 (diff)
downloadpackages-a9317a57f10e562a57e3a964868688aef8a70129.tar.gz
packages-a9317a57f10e562a57e3a964868688aef8a70129.tar.bz2
packages-a9317a57f10e562a57e3a964868688aef8a70129.tar.xz
packages-a9317a57f10e562a57e3a964868688aef8a70129.zip
user/perl-ipc-run: new package
Diffstat (limited to 'user/perl-ipc-run/APKBUILD')
-rw-r--r--user/perl-ipc-run/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/perl-ipc-run/APKBUILD b/user/perl-ipc-run/APKBUILD
new file mode 100644
index 000000000..c78ee10fb
--- /dev/null
+++ b/user/perl-ipc-run/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-ipc-run
+pkgver=20180523.0
+pkgrel=0
+pkgdesc="system() and background procs w/ piping, redirs, ptys"
+url="https://metacpan.org/pod/IPC::Run"
+arch="noarch"
+license="GPL-1.0+ OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/T/TO/TODDR/IPC-Run-$pkgver.tar.gz"
+builddir="$srcdir/IPC-Run-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="e9d97cbec9f2607d1a89c1a06bd166ae2f030157f201e870df3b88b9f0b915b06a4b0db05b7f50daa4883de255e29c6898b1f9964d706739d4bf7034b53d7f89 IPC-Run-20180523.0.tar.gz"