summaryrefslogtreecommitdiff
path: root/user/perl-json-xs
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-09-26 00:07:43 -0700
committerDan Theisen <djt@hxx.in>2018-09-26 00:07:43 -0700
commit579115b488251fac1264e3006661377bc7041134 (patch)
treedfe9290d756207e44a95f73e9d00ed2bb980b852 /user/perl-json-xs
parent2e474d213dff56545646a0b838455784f302ac3e (diff)
downloadpackages-579115b488251fac1264e3006661377bc7041134.tar.gz
packages-579115b488251fac1264e3006661377bc7041134.tar.bz2
packages-579115b488251fac1264e3006661377bc7041134.tar.xz
packages-579115b488251fac1264e3006661377bc7041134.zip
user/perl-json-xs: new package
Diffstat (limited to 'user/perl-json-xs')
-rw-r--r--user/perl-json-xs/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/perl-json-xs/APKBUILD b/user/perl-json-xs/APKBUILD
new file mode 100644
index 000000000..75f0720ce
--- /dev/null
+++ b/user/perl-json-xs/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-json-xs
+pkgver=3.04
+pkgrel=0
+pkgdesc="JSON serialising/deserialising, done correctly and fast"
+url="https://metacpan.org/pod/JSON::XS"
+arch="all"
+license="Artistic-1.0-Perl AND GPL-2.0"
+depends="perl perl-common-sense perl-types-serialiser"
+makedepends="perl-dev perl-canary-stability"
+install=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/M/ML/MLEHMANN/JSON-XS-$pkgver.tar.gz"
+builddir="$srcdir/JSON-XS-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="69c2e199385b5b5e331d905b64805304de80e1a3b393acaf7dce21c45254b1f23f1a83b246dcd3a80c2cfdadaf8ce3634ee587c469629cb69106f0c2239c73db JSON-XS-3.04.tar.gz"