summaryrefslogtreecommitdiff
path: root/user/perl-params-validate/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-02 01:22:01 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-02 01:22:01 +0000
commit5f75f8261b0edb63ed8ba1ad5c0d774270a0249f (patch)
tree8131d0a0f865c42faff7e7277dbbb446e3830030 /user/perl-params-validate/APKBUILD
parent05d831a03f22c9cc5b7b4bb4c63151b16246cfbe (diff)
downloadpackages-5f75f8261b0edb63ed8ba1ad5c0d774270a0249f.tar.gz
packages-5f75f8261b0edb63ed8ba1ad5c0d774270a0249f.tar.bz2
packages-5f75f8261b0edb63ed8ba1ad5c0d774270a0249f.tar.xz
packages-5f75f8261b0edb63ed8ba1ad5c0d774270a0249f.zip
user/perl-params-validate: new package
Diffstat (limited to 'user/perl-params-validate/APKBUILD')
-rw-r--r--user/perl-params-validate/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/perl-params-validate/APKBUILD b/user/perl-params-validate/APKBUILD
new file mode 100644
index 000000000..64d524648
--- /dev/null
+++ b/user/perl-params-validate/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-params-validate
+pkgver=1.29
+pkgrel=0
+pkgdesc="Validate Perl method/function parameters"
+url="https://metacpan.org/release/Params-Validate"
+arch="all"
+license="Artistic-2.0"
+depends="perl-module-implementation"
+makedepends="perl-dev perl-module-build"
+checkdepends="perl-test-fatal perl-test-requires"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/Params-Validate-$pkgver.tar.gz"
+builddir="$srcdir/Params-Validate-$pkgver"
+
+build() {
+ cd "$builddir"
+ perl Build.PL installdirs=vendor
+ ./Build
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
+}
+
+package() {
+ cd "$builddir"
+ ./Build install destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="afa887d1ce60d38b82cbf3ad88fb892f473e0fa45db528b68e66bbb800058af453180cc96afddae56a2cdad8ec531a587e7aac36b6869c489caa6dd36a57a385 Params-Validate-1.29.tar.gz"